Closed Bug 1740124 Opened 11 months ago Closed 11 months ago

The Profile Manager is incorrectly displayed when the system has different scaling on 2 monitors (wayland)

Categories

(Core :: Widget: Gtk, defect)

Desktop
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1737358
Tracking Status
firefox96 --- affected

People

(Reporter: danibodea, Unassigned)

References

(Blocks 2 open bugs)

Details

Attachments

(2 files, 1 obsolete file)

Attached file scaling issue on profile manager 1 (obsolete) —

Note

  • When the user sets different scaling on his (at least) 2 monitors and opens the profile manager in wayland window protocol, he will notice that the UI is incorrectly displayed on one of the monitors.

Affected versions

  • Nightly v96.0a1

Affected platforms

  • Ubuntu 21.04 + wayland

Prerequisites

  • Have at least 2 working monitors on your system.
  • Set one with 100% "Scale" and the other with 100% "Scale".

Steps to reproduce

  1. Open the profile manager in wayland:
    a. Go into the nightly folder.
    b. Right-click and "Open in Terminal".
    c. MOZ_ENABLE_WAYLAND=1
    d. ./firefox
  2. Notice the Profile manager window scaling; Move it on the other monitor.

Expected result

  • The scaling is properly translated between the two monitors.

Actual result

  • The UI of the window is improperly displayed.

Regression range

  • Unkbown.

Additional notes

  • This issue occurs with "wayland" Window Protocol and not with "xwayland".
Attachment #9249872 - Attachment is obsolete: true
Component: Audio/Video → Widget: Gtk

This bug is duplicate of bug 1737358

Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1737358
You need to log in before you can comment on or make changes to this bug.