Closed Bug 17403 Opened 22 years ago Closed 13 years ago

cache clearing on exit

Categories

(Core :: Networking: Cache, enhancement, P4)

enhancement

Tracking

()

RESOLVED WORKSFORME
Future

People

(Reporter: 4jgm1, Assigned: gordon)

References

Details

(Keywords: helpwanted)

You guys would be super-heroes if you could add into the next Netscape a
feature that automatically cleared the CACHE when you exit Netscape (for those
who enable the feature).  Let's face it - it would take about 3 seconds to
implement and be of immense benefit for those who do on-line mail, etc.!!
Please consider it, I know a LOT of people who would love you all the more
because of it!! It would be great marketing for you!
See bug #11008 for a manual version of this.  Maybe this should be marked a
duplicate and an automatic option suggested on there.
Assignee: leger → gagan
Severity: normal → enhancement
Component: Browser-General → Cache
QA Contact: leger → tever
Target Milestone: M15
Setting component/QA contact.
very good idea. cc'ing fur our new Cache Man!
Summary: [RFE]cache clearing on exit
Status: NEW → ASSIGNED
Bulk move of all Cache (to be deleted component) bugs to new Networking: Cache
component.
Assignee: gagan → davidm
Status: ASSIGNED → NEW
->davidm
Keywords: beta2
I like matty idea of duping this.


*** This bug has been marked as a duplicate of 11008 ***
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
VERIFY dupe
Status: RESOLVED → VERIFIED
Keywords: nsbeta2
reopening, see bug 11008 comment 19.

This feature was suggested in bug 11008, but there's no agreement that
this will be implemented. Resolve this as WONTFIX if fix to 11008 will
not cover this and the bug owner will not implement this.
Status: VERIFIED → REOPENED
Depends on: ClearAll
Resolution: DUPLICATE → ---
Summary: [RFE]cache clearing on exit → cache clearing on exit
Target Milestone: M15 → ---
-> gordon
Status: REOPENED → NEW
-> gordon
Assignee: davidm → gordon
Status: NEW → ASSIGNED
Priority: P3 → P4
Target Milestone: --- → Future
*** Bug 214924 has been marked as a duplicate of this bug. ***
This isn't hardware or OS specific.  Someone should update those fields.
Re Comment #12, you're right. Updating fields.

Just curious, we already have the code to clear the cache, so we just need a UI
interface to that code.

Anyone want to point me (or whoever else finds some spare time) to the files
concerned?
OS: Windows 95 → All
Hardware: PC → All
It appears MultiZilla is working on this feature and already has it implemented.
 See http://multizilla.mozdev.org/docs/status-updates/latest.html for more
information.  Perhaps this can help in getting it implemented over here.
*** Bug 226192 has been marked as a duplicate of this bug. ***
Good idea Grant. Who's following up on this ?
*** Bug 239379 has been marked as a duplicate of this bug. ***
No longer depends on: ClearAll
Anyone still working on this?
(In reply to comment #18)
> Anyone still working on this?

no one is working on this.  adding helpwanted keyword.  patches welcome.
Keywords: helpwanted
(In reply to comment #19)
> (In reply to comment #18)
> > Anyone still working on this?
> 
> no one is working on this.  adding helpwanted keyword.  patches welcome.

I have a patch. See bug 11008 for details.
*** Bug 275057 has been marked as a duplicate of this bug. ***
*** Bug 285717 has been marked as a duplicate of this bug. ***
*** Bug 291349 has been marked as a duplicate of this bug. ***
Isn't this covered by "Clear Private Data upon close"?
(In reply to comment #24)
> Isn't this covered by "Clear Private Data upon close"?
Yeah, this is implemented in Firefox now.
Status: ASSIGNED → RESOLVED
Closed: 22 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.