If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

IMAP server unreachable hangs browser.

RESOLVED FIXED

Status

MailNews Core
Networking: IMAP
RESOLVED FIXED
15 years ago
9 years ago

People

(Reporter: John Malmberg, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
If I set up Mozilla to launch both a browser window and the Mail/News client
when the broadband Internet is down, the browser is unable to reach any local
web servers.

Mozilla 1.1

Mozilla/5.0 (X11; U; OpenVMS COMPAQ_AlphaServer_DS10_466_MHz; en-US; rv:1.1)
Gecko/20020828

Comment 1

15 years ago
How are you specifying your local servers, by name or by address. If by name,
what (or rather where) is you DNS host?
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 2

15 years ago
Also, do you have a proxy server defined?
(Reporter)

Comment 3

15 years ago
The TCPIP database only contains the hosts on the local LAN.  The Name service
is pointed at the ISP's DNS.

There is no proxy server.

Updated

15 years ago
QA Contact: huang → gchan

Comment 4

15 years ago
John,

Sorry I haven't gotten back to you on this one. It is not assigned to me and it
slipped through the cracks.

Is this still a problem on Mozilla 1.3? If so, can you provide more info? For
example, could the mail part of Mozilla be blocked on a DNS lookup (I think this
will also block other threads doing name lookups)? Are you trying to access the
local web server by name of ip address? Can you ping the local web server
successfully? 
(Reporter)

Comment 5

15 years ago
I will try to test this soon.

The mail part of Mozilla could very well be blocked on a DNS lookup.

My configuration is that I have a local TCPIP DNS server that queries the ISP
DNS if it can not resolve the name.  The TCPIP BIND server caches entries, so I
do not know if it needed to do a DNS lookup or not.

The local web server is looked up from the TCPIP$HOST file, and is usually
invoked by name.  There is no problem pinging the local web server.  It is the
administrative interface to my firewall.

Comment 6

15 years ago
Still a problem? One thing I fixed recently for OpenVMS was to put a lock around
the DNS lookups, since on OpenVMS these routines are not reentrant. Not sure
exactly when this fix first saw the light of day, but its in 1.4 beta for sure.

Comment 7

14 years ago
Via email John reports: The case where starting e-mail and the browser both at
startup with no internet connection does appear to have been fixed.

Closing bug report.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.