Closed Bug 1740630 Opened 3 years ago Closed 3 years ago

Printing selection from parent process browsers is broken and disabled

Categories

(Toolkit :: Printing, defect)

defect

Tracking

()

RESOLVED FIXED
96 Branch
Tracking Status
firefox-esr91 --- fixed
firefox96 --- fixed

People

(Reporter: darktrojan, Assigned: darktrojan)

References

Details

Attachments

(2 files)

While looking into selection printing in Thunderbird (bug 1731183) I discovered that printing the selection from the parent process is disabled because it doesn't work properly. It doesn't work properly because this code is trying to get the selection from the print settings window instead of the window being printed. That can be fixed.

Attachment #9250305 - Attachment description: Bug 1740630 - Fix and enable printing the selection from a parent process browser. r=mstriemer → Bug 1740630 - Fix and enable printing the selection from a parent process browser. r=emilio
Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/integration/autoland/rev/e9cb0621e5a1
Fix and enable printing the selection from a parent process browser. r=emilio
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 96 Branch

Comment on attachment 9250305 [details]
Bug 1740630 - Fix and enable printing the selection from a parent process browser. r=mstriemer

Beta/Release Uplift Approval Request

  • User impact if declined: Firefox users are largely unaffected, but Thunderbird users are unable to print only a selection. I'd like this to make it to Thunderbird 91.4.0 if possible.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky):
  • String changes made/needed:
Attachment #9250305 - Attachment description: Bug 1740630 - Fix and enable printing the selection from a parent process browser. r=emilio → Bug 1740630 - Fix and enable printing the selection from a parent process browser. r=mstriemer
Attachment #9250305 - Flags: approval-mozilla-beta?

Comment on attachment 9250305 [details]
Bug 1740630 - Fix and enable printing the selection from a parent process browser. r=mstriemer

It seems that you want it on the ESR branch, not Firefox 95 beta branch.

Attachment #9250305 - Flags: approval-mozilla-beta? → approval-mozilla-esr91?

Well yes, but is going to beta first not a requirement?

Flags: needinfo?(pascalc)

(In reply to Geoff Lankow (:darktrojan) from comment #6)

Well yes, but is going to beta first not a requirement?

I am not comfortable taking this patch into beta because this landed recently on mozilla-central and our RC week is next week, also although this uplift says that this was verified in nightly, I don't think it was done by QA. Historically, changes in our printing code tends to lead to regressions so I'd prefer to have this patch ride the train and uplift in ESR 91.5.0 or 91.6.0, the time for potential regressions to be reported. Given that unlike for Firefox, this bug has a high impact on Thunderbird, I understand that this is something you'd like to see in your next point release, I guess that you can cherry-pick this patch for TB91.4.0 until we land it on ESR though?

Flags: needinfo?(pascalc) → needinfo?(geoff)

We don't have an ESR branch to cherry-pick it to. We use mozilla-esr91. Whatever, it can wait a cycle, it's been several months already, a few more weeks won't hurt.

Flags: needinfo?(geoff)

Good call. It can wait a cycle

Which current or future version of Thunderbird has/will have this? TB 96.0b2 does not.

Attached image print-selection.png

Which current or future version of Thunderbird has/will have this? TB 96.0b2 does not.

Yes it does.

I really don't understand. I'm using TB 96.0b2 (64-bit) on a Mac. Selecting a subset of text in the message, then File/Print, results in the whole message, including headers, to be printed. I have no (obvious) conflicting add-ons.

(In reply to Gary Hooper from comment #12)

I really don't understand. I'm using TB 96.0b2 (64-bit) on a Mac. Selecting a subset of text in the message, then File/Print, results in the whole message, including headers, to be printed. I have no (obvious) conflicting add-ons.

Never mind. I now see the "Selection" option after unhiding it.

In older versions, I believe that this was automatic, meaning that if a selection existed, only the selected area was printed, without explicitly having to indicate so.

Comment on attachment 9250305 [details]
Bug 1740630 - Fix and enable printing the selection from a parent process browser. r=mstriemer

Approved for 91.5esr.

Attachment #9250305 - Flags: approval-mozilla-esr91? → approval-mozilla-esr91+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: