Plugin Downloader Plugin reported as missing

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: andre.bugs2, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
With a CVS build from a few minutes ago Phoenix reports that the Plugin
Downloader Plugin is not present. This happens if I go to a page that requests a
plugin which I do not have installed. The libnullplugin.so file is present in
the build but Phoenix does not appear to find it.
(Reporter)

Comment 1

16 years ago
Ok, this is much more subtle than I thought at first. You actually have to visit
Customize Toolbar before you can see this! Steps to reproduce:

1) Launch Phoenix and go to Customize Toolbar
2) Click OK
3) Go to a website that needs a plugin you don't have (java in my case).

Result: The message about missing Plugin Downloader Plugin appears. If steps 1-2
are ignored it doesn't happen.

Comment 2

16 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021012 Phoenix/0.3

The circumstances where this happens seem to be unpredictable. For example, I
went to the following page (Java applet):

http://java.sun.com/docs/books/tutorial/applet/practical/properties.html

I got the "plugin downloader plugin" message. After quitting Phoenix and
restarting, I was able to go to that page and view the applet.

I also noticed that PDF files sometimes stop working in the Acrobat plugin;
instead Phoenix asks me to download them.

When this happens, if you go to about:plugins you will see the message "No
plug-ins are installed."

Comment 3

16 years ago
If it wasn't clear in my previous message: I do have Java installed and working.
I did not do the Customize Toolbar steps that André proposed, yet I still saw
the "plugin downloader plugin" message.

Comment 4

16 years ago
IMHO, this should be fixed for phoenix0.3. This is a show stopper :-(

Comment 5

16 years ago
Changing to All/All as I see this on Windows2000.
OS: Linux → All
Hardware: PC → All

Comment 6

16 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021016 Phoenix/0.3

I have not experienced this problem in the last several builds. I assume it's
fixed. Removing my name from CC: list.
(Reporter)

Comment 7

16 years ago
I don't see this anymore either. Resolving as WORKSFORME since I don't know what
checkin fixed this.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

16 years ago
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.