Closed Bug 1741688 Opened 2 years ago Closed 2 years ago

Update googletest to 1.11.0

Categories

(NSS :: Test, enhancement, P1)

3.73
x86_64
Linux
enhancement

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: johny, Assigned: johny)

References

()

Details

Attachments

(1 file)

Steps to reproduce:

Running the NSS build with gcc 11.1.0 results in the error described in this issue in the googletest repository:
https://github.com/google/googletest/issues/3219

Expected results:

I suggest updating the bundled googletest library to 1.11.0 which has the fix for this issue. I will send a patch soon.

OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED

Thank you Ján!

Assignee: nobody → johny
Severity: -- → N/A
Priority: -- → P1
Target Milestone: --- → 3.74
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---

nss-try before the backout:
https://treeherder.mozilla.org/jobs?repo=nss-try&revision=0ca2421af398589a32036dbc0bf547a74cd9b729

nss-try for the backout:
https://treeherder.mozilla.org/jobs?repo=nss-try&revision=84019f428138de0ea339e73ba653787f4c25e6d5

Looks like a few changes are needed... Ján, could you have a look?
I suggest keeping the current commit and add one on top with the changes to NSS.
(We can push to the CI for you if you need to test changes.)

Flags: needinfo?(johny)

I took a brief look at this and there is one easy problem and one hard one.

The easy one is that we instantiate tests for TlsAgentTestClient without defining a single TEST_P() for that class. Removing the instantiation works fine.

The hard one is that googletest doesn't compile with g++ 4.8. From what I can tell on their status page, c++11 was in the development process when gcc 4.8 shipped, so we've been coasting on that. I think that the right answer is to cut the C++ tests from our gcc 4.8 builds. We get most of the value from those tests running under a modern compiler, so losing this won't hurt that much. I'm happy to fix that up.

Any movement on this? Still can't work on the library with modern gcc.

Depends on: 1760827
Depends on: 1760828

Hi Ján,

Sorry this was left on the backburner after bouncing out due to CI failures. I've rebased your changes onto the latest NSS, fixed the issue and added a CI target for gcc-11. We should get your changes into the release next week.

Best,
Dennis

Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.