Closed Bug 1741805 Opened 2 months ago Closed 2 months ago

"Sending of the message failed. There was an error attaching xxx.pdf. Please check that you have access to the file."

Categories

(MailNews Core :: Composition, defect)

Thunderbird 91
defect

Tracking

(thunderbird_esr91+ fixed, thunderbird95 fixed)

RESOLVED FIXED
96 Branch
Tracking Status
thunderbird_esr91 + fixed
thunderbird95 --- fixed

People

(Reporter: byohorse, Assigned: rnons)

References

(Blocks 1 open bug, )

Details

Attachments

(4 files)

Attached image Thunderbird issue.JPG

Steps to reproduce:

I use several Filters in my Thunderbird to forward documents. Have used the same Filters for many months with no problem.
When I collected my emails, those with attachments that were supposed to forward received an error message.
"Sending of the message failed. There was an error attaching xxx.pdf. Please check that you have access to the file."

Actual results:

The messages did not forward but the rest of the filter continued (ie moved them to a folder identified in the Filter.

Expected results:

The message should have forwarded (and has always done so until now).
Having spoken to fellow Thunderbird users, they have also the same problem yesterday and today.
Exactly the same error message, different ISPs, different email addresses, different computers (and actually, different parts of the country).

Duplicate of this bug: 1741846
Assignee: nobody → remotenonsense
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Version: 9 Branch → Thunderbird 91

To prevent ~nsMsgComposed being called before sending finishes.

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/35876265390b
Wait for SendMsg in nsMsgComposeService.cpp to prevent ~nsMsgComposed being called before sending finishes. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

I have tested this since it was resolved and still getting exactly the same error.
When using a Filter to forward a message with an attachment, it is still saying "Sending of the message failed. There was an error attaching xxx.pdf. Please check that you have access to the file."
I have ensured my Thunderbird is up to date and have closed, and opened the software several times. Still happening.
Can you please reinvestigate the issue.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

This bug is unresolved.
Message filter forwarding is needed by many users and is therefore having a serious impact.
They have been forced to downgrade to TB78 or move to Outlook.
I hope it will be fixed as soon as possible with the highest priority.

The version in which this bug is occurring is:

  • 91.3.1
  • 91.3.2

This bug has not occurred below:

  • 78
  • 91.0 - 91.3.0
  • 95.0b3
  • 96.0a1 (20211121114531)

When I forwarded the message with the message filter, it seemed to me that no temporary attachment was generated in the temporary folder of Windows.
I'm ready to collect logs if instructed.

Flags: needinfo?(remotenonsense)

Is there any update on this?
Still getting the same error.
Version 91.3.2
Thanks

I have the same problem on version 91.3.2 and on prior versions.

Inbound email has a pdf attachment.
Filter on inbox is supposed to forward the message to another email address.
Result:
Message pops up:"Sending of the message failed." "There was an error attaching {attachment_filename}. Please check that you have access to the file."
The incoming message now has an indicator that it has been forwarded.
Message has NOT been forwarded.

Run filter on folder and the error will repeat.

Also for me, filters do not work with mail forwarding. You have to wait for the correct version to be released.

facing same issue since many days
attachments not getting forwarded through filters, getting the same error. and its creating a lot of issues
im on 91.3.2
someone kindly rectify this urgently

This doesn't only happen when filters are in use.
If I send an e-mail with an attachment using a distribution list of 100, it will normally fail with the error message that has already been described after sending about 30.

The developer will be back in a few days and can address it then.

Blocks: tb91found

We set a bug to resolved when the patch landed to the trunk, which becomes daily build. According to comment 6

This bug has not occurred below:
78
91.0 - 91.3.0
95.0b3
96.0a1 (20211121114531) --- this is the daily build

I will request uplifts now, please wait a few days for it to reach beta and then esr91, thanks.

Status: REOPENED → RESOLVED
Closed: 2 months ago2 months ago
Flags: needinfo?(remotenonsense)
Resolution: --- → FIXED

Comment on attachment 9251512 [details]
Bug 1741805 - Wait for SendMsg in nsMsgComposeService.cpp. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #): bug 1741846
User impact if declined: Forwarding message with attachments doesn't work in filters
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9251512 - Flags: approval-comm-esr91?
Attachment #9251512 - Flags: approval-comm-beta?

Comment on attachment 9251512 [details]
Bug 1741805 - Wait for SendMsg in nsMsgComposeService.cpp. r=mkmelin

[Triage Comment]
Approved for beta

Attachment #9251512 - Flags: approval-comm-beta? → approval-comm-beta+
Duplicate of this bug: 1742833
Target Milestone: --- → 96 Branch

has this issue been resolved?
facing a lot of difficulties due to this error

(In reply to use ruser from comment #18)

has this issue been resolved?
facing a lot of difficulties due to this error

It will be in beta 95.0b5 (releasing in the next day). Suggest you TEST it in a new Thunderbird profile (unless you are already using beta). Available at https://archive.mozilla.org/pub/thunderbird/releases/95.0b5/

It will be in version 91 in the next few weeks. Possibly as early as next week.

ill prefer using it in version 91 itself
thanks for the update

Component: Filters → Composition
Product: Thunderbird → MailNews Core

rnons, I am OK with taking this with an anticipated respin of 91.4.0 (build 2). Are you OK with that? If so, please request uplift.

Flags: needinfo?(remotenonsense)

Sorry, I'm not convinced the patch fixes the problem, because it works for me even without the patch.

For those of you seeing the problem, can you tell me the value of mail.forward_message_mode? 0 means forward as attachment, 2 means forward inline, you can check the value from the Config Editor on Settings page. You can also try changing it to 0 or 2 to see if it's the same. Thanks.

Flags: needinfo?(remotenonsense)

mine shows 2

  • in ~nsMsgCompose, remove tmp attachments only if mMsgSend is not inited
  • remove tmp attachments after mMsgSend->CreateAndSendMessage returns
  • add tests for forwarding messages in filters
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment on attachment 9251512 [details]
Bug 1741805 - Wait for SendMsg in nsMsgComposeService.cpp. r=mkmelin

Will make a new patch for esr91 tomorrow.

Attachment #9251512 - Flags: approval-comm-esr91?

Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/comm-central/rev/c152f5ce3a78
Prevent tmp attachments being removed before msg is created in nsMsgCompose. r=mkmelin

Status: REOPENED → RESOLVED
Closed: 2 months ago2 months ago
Resolution: --- → FIXED

[Approval Request Comment]
This patch also fixes bug 1741596, the problem is the same, tmp attachments get deleted too soon.

Attachment #9253557 - Flags: approval-comm-esr91?

this patch resolves the issue?
does it have to be downloaded or something or will it be pushed to thunderbird automatically via update?

Comment on attachment 9253557 [details] [diff] [review]
1741805-esr91.patch

[Triage Comment]
Approved for esr91

(In reply to use ruser from comment #28)

this patch resolves the issue?
does it have to be downloaded or something or will it be pushed to thunderbird automatically via update?

version 91.4.0, as indicated in comment 19 and 21

Attachment #9253557 - Flags: approval-comm-esr91? → approval-comm-esr91+
Duplicate of this bug: 1742231

when is this getting pushed out to us?

(In reply to use ruser from comment #32)

when is this getting pushed out to us?

it is available

Duplicate of this bug: 1744776
You need to log in before you can comment on or make changes to this bug.