starmed.co.il - pharmacies section doesn't work, graphics simplified

RESOLVED FIXED

Status

Tech Evangelism
Desktop
RESOLVED FIXED
16 years ago
3 years ago

People

(Reporter: Tsahi Asher, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [country-il], URL)

(Reporter)

Description

16 years ago
well, this site blocks mozilla and mozilla based (or at least my netscape 7)
browsers. attempting to enter redirects to http://213.8.75.75/nonIE5Plus.asp ,
where a ridiculus claim that an "advanced browser such as IE5" is needed.

contact info: http://www.starmed.co.il/Feedback/ (IE only)
(Reporter)

Comment 1

16 years ago
one more thing, don't know if it's important: the site's business is a vertical
portal about health and related subjects.

Comment 2

16 years ago
Verified in build 2002101612 PC/Win98.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

15 years ago
tech evang june 2003 reorg
Assignee: momoi → hebrew
Component: Middle Eastern → Hebrew
QA Contact: xslf → hebrew

Comment 4

15 years ago
Yet another site which lives in the past, and claimes that mozilla does not
support logical Hebrew.

Any way to contact them without MSIE (I do not have acces to that browser)?
Whiteboard: [deny]
(Reporter)

Comment 5

15 years ago
i was once contacted by their webmaster: webmaster@starmed.co.il
(Reporter)

Comment 6

15 years ago
sent them a message about the false claims in their blocking message, with a
link to http://www.mozilla.org/projects/tech-evangelism/site/resources.html and
to this bug.

Comment 7

14 years ago
site can now be accessed with Mozilla without problems
But there's one problem left(?): Look at the blue tabs with the white chars on
it, in IE it seems the tabs are sorted the other way round. Tsahi Asher, can you
say something to this, is this right or wrong or doesn't it matter (i don't
understand Hebrew, so i can't tell :). 
(Reporter)

Comment 8

14 years ago
the text in the tabs is right, but the order of the tabs is indeed reversed. if
that were the only problem, i wouldn't object to mark this bug fixed, but it's not.

1. the forums (http://www.starmed.co.il/Forums/) served to mozilla are a "dumbed
down" version of what is served to IE.
2. the parmacies section (http://www.starmed.co.il/Pharmacies/) doesn't work. in
IE it shows a list of all pharmacies in the country, divided to 25 per page. in
mozilla it doesn't. the drop-down menu at the top should give you an option to
select a town.
3. in the right nav bar, the link over which the mouse is, is shaped like a
button (top/left margin white, button/right margin grey) in IE, and not in mozilla.
4. in the about page (http://www.starmed.co.il/About) the header in IE is
"pasted" letter by letter in a quick animation. in mozilla it's a simple <h1>.
5. the headers in medical insurances (http://www.starmed.co.il/Insurance/) are
also "dumbed down" for non-IE.

in summary, there are a bunch of cosmetical problems for mozilla, and some real
problems (like the parmacies section.
Summary: starmed.co.il - site blocks mozilla → starmed.co.il - pharmacies section doesn't work, graphics simplified
Whiteboard: [deny]
(Reporter)

Comment 9

14 years ago
i just noticed: if you'll try to see a reply to a poll at
http://www.starmed.co.il/Poll/74, you'll see the blocking message that was at
the front page when this bug was opened.
(Reporter)

Comment 10

14 years ago
sorry for the bugspam, but just for completeness: click any of the links at
http://www.starmed.co.il/Calculators/ and you'll also be blocked away.
(Reporter)

Comment 11

12 years ago
update: calculators are not blocked, but don't work either. the main page is encoded in UTF-8, because the server sends this http header:

Content-Type:	text/html; Charset=windows-1255; Charset=utf-8

but the html source has

<meta http-equiv="Content-Type" content="text/html; charset=windows-1255">

other pages, like http://www.starmed.co.il/Men/ , send just

Content-Type:	text/html; Charset=windows-1255

so there's no encoding problem.

every page load starts some script that never stops, unless you stop it with mozilla's alert window.

Comment 12

9 years ago
Update: calculators still don't work, js console throws some errors.

Comment 13

4 years ago
It ain't the prettiest site I've seen but it's functional.
Can you please recheck?
Flags: needinfo?(tsahi_75)
This seems to be fixed.
Assignee: hebrew → nobody
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Component: Hebrew → Desktop
Resolution: --- → FIXED
Whiteboard: [country-il]
(Reporter)

Comment 15

3 years ago
It looks mostly working in both firefox and IE. Only the BMI calculator doesn't work in FF, with no errors in the console. it uses document.all to do the calculation.
Flags: needinfo?(tsahi_75)
Maybe open a new bug describing how to reproduce the BMI calculator problem?
You need to log in before you can comment on or make changes to this bug.