Closed Bug 1742788 Opened 10 months ago Closed 10 months ago

For loading search-config, enable reloading a collection from the local dump if it is newer than the database

Categories

(Firefox :: Search, task, P2)

task

Tracking

()

VERIFIED FIXED
96 Branch
Tracking Status
firefox95 + verified
firefox96 --- verified
firefox97 --- verified

People

(Reporter: standard8, Assigned: standard8)

References

Details

Attachments

(1 file)

Bug 1717068 has enabled reloading a collection from the local dump if that dump is newer than what is in the database.

One benefit of this, is that if remote settings is unable to update for any reason then we'll still reload the collection when an application update is applied.

The check is performed via timestamps comparison, the timestamps for the local dump are in a separate file so the main (big) dump does not have to be parsed. Therefore I don't think there would be any significant performance impact here so I think it is good to enable for better stability.

Please add me as a reviewer.

Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5fa7ec49d934
Enable loading from the local dump if it is newer for the search-config remote settings collection. r=robwu,daleharvey
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 96 Branch

Comment on attachment 9252313 [details]
Bug 1742788 - Enable loading from the local dump if it is newer for the search-config remote settings collection. r?robwu!,mkaply!

Beta/Release Uplift Approval Request

  • User impact if declined: Old search settings are used when mint is upgraded.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Already working with QA for testing.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): automated test
  • String changes made/needed:
Attachment #9252313 - Flags: approval-mozilla-release?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Comment on attachment 9252313 [details]
Bug 1742788 - Enable loading from the local dump if it is newer for the search-config remote settings collection. r?robwu!,mkaply!

Approved for a 95 dot release, thanks.

Attachment #9252313 - Flags: approval-mozilla-release? → approval-mozilla-release+

Already tested on 95 (here) and since this is riding 95.0.1, updating flags.

Verified on Linux Mint Cinnamon 20.2, Windows 10, Mac 11 using 97.0a1 (2022-01-05) and RC 96.0 2022-01-03.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.