Closed Bug 1744442 Opened 8 months ago Closed 5 months ago

All day events don't have the start/end time widget disabled

Categories

(Calendar :: Dialogs, defect)

Thunderbird 91
defect

Tracking

(thunderbird_esr91 wontfix)

RESOLVED FIXED
100 Branch
Tracking Status
thunderbird_esr91 --- wontfix

People

(Reporter: rachel, Assigned: rachel)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:91.0) Gecko/20100101 Firefox/91.0

Steps to reproduce:

Create an event, make it all day. As soon as you click the "all day" check box, the start and end time input should be disabled like it was in TB 78. The same happens when editing an all day event.

Alice, could you please find the regression. This is very straight forward. Working in TB 78, not working in TB 91, of 95 beta. Didn't try Daily.

Blocks: tb91found
Flags: needinfo?(alice0775)
Keywords: regression

I can reproduce using 95.0b5 if you mean not dimmed, indicating it is disabled.

I can't make any changes to the times, only the date, and would consider that as disabled.

Yes, the time picker appears, but changes are discarded. Please compare to the TB 78 behaviour.

(In reply to Rachel Martin from comment #3)

Yes, the time picker appears, but changes are discarded. Please compare to the TB 78 behaviour.

Discarded means the same as disabled to me. I can't make a time change, never paid attention to how it was in previous versions because I was creating an All Day event.

Flags: needinfo?(mkmelin+mozilla)
Blocks: 1759486
Flags: needinfo?(mkmelin+mozilla)
Attachment #9269346 - Flags: review+
Assignee: nobody → rachel
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → 100 Branch
See Also: → 1742911
See Also: → 1752898

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/b4d4250e3f1d
Fix non-disabled time widgets for all day events, use set/removeAttribute() instead of toggleAttribute(). r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.