Closed Bug 17454 Opened 25 years ago Closed 25 years ago

Search of pluglets by mime-type should not be case sensitive

Categories

(Core Graveyard :: Java-Implemented Plugins, defect, P3)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: lvv, Assigned: blackconnect)

Details

Overview Description:
Now (the build on October 27, 1999) the search of corresponding pluglet is case
sensitive.

Steps to Reproduce:
 1) place in manifest file of pluglet this string:

MIMEDescription: application/x-simple-pluglet::Pluglet Test

 2) load html file with this string:

<EMBED type="APPLICATION/x-simple-pluglet" name="test" width=400 height=200>


Actual Results:
The pluglet will not be found.

Expected Results:
The value of the type attribute of the embed tag is case insensitive,
so the pluglet should be found.

Additional Information:
The reason for the bug is case sensitive comparison in
java/plugins/src/Pluglet.cpp file in method Pluglet::Compare()
Status: NEW → RESOLVED
Closed: 25 years ago
Resolution: --- → FIXED
Suggested fix:
change strcmp to PL_strncasecmp in Pluglet::Compare()
Verified with Mozilla 0.9.5 (Mozilla/5.0 (Windows; U; WinNT4.0; en-US; 
rv:0.9.5+) Gecko/20011030).
Pluglets now is case insensitive.
VERIFIED
Status: RESOLVED → VERIFIED
QA Contact: leila.garin → avm
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.