Delete Table command doesn't work

RESOLVED FIXED in mozilla1.2final

Status

SeaMonkey
Composer
--
minor
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: Jim Booth, Assigned: Charles Manske)

Tracking

({regression})

Trunk
mozilla1.2final
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.2b) Gecko/20021015
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.2b) Gecko/20021015

The DELETE TABLE command from the menu or the right-click menu stopped working
sometime between the 20021005 and 20021012 builds.

You can delete a table by deleting the last row, but the delete table command
does nothing.


Reproducible: Always

Steps to Reproduce:
1. Open a blank composer document
2. Insert any table
3. With the caret in the table, try to delete the tanle with Table/DeleteTable
or right-click and select Table Delete/Table
Actual Results:  
The table is not deleted

Expected Results:  
The table should be deleted

Comment 1

16 years ago
CHarley, please check this out...
Assignee: syd → cmanske
(Assignee)

Comment 2

16 years ago
Oops! A trivial spelling mistake in ComposerCommands.js:
      GetCurrentEditor().delectTable();
should be
      GetCurrentEditor().deleteTable();
I'm already making a lot more changes to ComposerCommands.js, so I'll include
the fix there.
Status: UNCONFIRMED → ASSIGNED
Depends on: 169029
Ever confirmed: true
Target Milestone: --- → mozilla1.2beta

Comment 3

15 years ago
can this get fixed for 1.2final?
Keywords: nsbeta1, regression
OS: Windows ME → All
Hardware: PC → All
Whiteboard: editorbase
Target Milestone: mozilla1.2beta → mozilla1.2final
(Assignee)

Comment 4

15 years ago
Yes! I will try to get this in ASAP.
I fully expected to be checking in all other changes to ComposerCommands.js,
but unfortunately, that won't be happening :(
(Assignee)

Comment 5

15 years ago
Created attachment 104686 [details] [diff] [review]
fix v1

Updated

15 years ago
Attachment #104686 - Flags: review+

Comment 6

15 years ago
Comment on attachment 104686 [details] [diff] [review]
fix v1

r=brade

Comment 7

15 years ago
Comment on attachment 104686 [details] [diff] [review]
fix v1

sr=kin@netscape.com
Attachment #104686 - Flags: superreview+
(Assignee)

Updated

15 years ago
Whiteboard: editorbase → editorbase [FIX IN HAND] need a=
(Assignee)

Updated

15 years ago
Whiteboard: editorbase [FIX IN HAND] need a= → [FIX IN HAND] need a=

Comment 8

15 years ago
Comment on attachment 104686 [details] [diff] [review]
fix v1

recent regression, firly visible, low-risk, my kinda fix. a=asa for checkin to
1.2 (on behalf of drivers)
Attachment #104686 - Flags: approval+
(Assignee)

Comment 9

15 years ago
Checked into 1.2final trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Whiteboard: [FIX IN HAND] need a=

Comment 10

15 years ago
*** Bug 178065 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

15 years ago
No longer depends on: 169029
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.