link location not shown in status bar after scrolling document

RESOLVED DUPLICATE of bug 50511

Status

--
minor
RESOLVED DUPLICATE of bug 50511
16 years ago
5 years ago

People

(Reporter: evert.verhellen, Assigned: asa)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2a) Gecko/20020910

Any time the mouse pointer lands on a hyperlink, either after scrolling the
document with the mouse wheel or a directional key, or after switching to
another tab, the link location of the hyperlink is not shown in the status bar,
nor does the mouse pointer change into a hand.

Reproducible: Always

Steps to Reproduce:
1. Start Mozilla.
2. Open a location.
3. Scroll the document with the mouse wheel or a directional key, such as
[Home], [End], [Up], [Down], [Page Up] or [Page Down], so that the mouse pointer
lands on a hyperlink afterwards. Alternatively, open another tab with [Ctrl]+[T]
and switch to the previous tab with either [Ctrl]+[Page Up] or [Ctrl]+[Page
Down] so that the mouse pointer lands on a hyperlink afterwards.
Actual Results:  
The link location of the hyperlink that the mouse pointer lands on is not shown
in the status bar, nor does the mouse pointer change into a hand.

Expected Results:  
The link location of the hyperlink that the mouse pointer lands on should be
shown in the status bar and the mouse pointer should change into a hand.

I think that there are a few rare exceptions where the link location *is* shown
and the mouse pointer *does* change, though after a few seconds only (as opposed
to immediately), but I haven't been able to consistently reproduce this. The
general rule is that it currently doesn't work.

Comment 1

16 years ago
I can reproduce the reported behavior, however i'm not sure that this is a
problem with mozilla per-se, but rather that mouse events (focus in) are not
delivered when scrolling either with the mouse or arrow/page up/down keys.

Either that, or they are being masked out due the new type-ahead link find
feature in mozilla. I didn't see a preference to turn off type-ahead link
finding in the preferences to prove/disprove this theory however.

This is a duplicate of a fairly old bug...
Whiteboard: DUPEME

Comment 3

16 years ago
Looks like bug 50511 is the original.

*** This bug has been marked as a duplicate of 50511 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.