POP Server IP and Round-Robin DNS

RESOLVED DUPLICATE of bug 162871

Status

defect
RESOLVED DUPLICATE of bug 162871
17 years ago
11 years ago

People

(Reporter: jhg, Assigned: mscott)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

17 years ago
Based on observation of current (1.1) behavior, Mozilla resolves the
POP server address the first time and caches the IP for subsequent
use.  Consider an ISP with round-robin DNS resolution to multiple
POP servers.  If one of those servers goes down, clients with
that IP cached stop working.

I suggest that Mozilla needs an option to force it to requery
DNS every time it goes to the POP/IMAP server for mail.  This will
be a great boon to all sysadmins fielding unreproducible 
"My mail doesn't work" complaints, especially where their ISP
went from a single POP server to four servers on round-robin DNS
without telling anyone :-)

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 162871 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
I can verify dupe, but I think this should be a depends, because mailnews is
going to have to start testing this separately, if this is ever fixed.

Updated

17 years ago
QA Contact: huang → gchan
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.