error occured while opening a javascript-popup-window. seems like url-parameters were lost. The parameter contains a ©

RESOLVED DUPLICATE of bug 174628

Status

()

Core
HTML: Form Submission
RESOLVED DUPLICATE of bug 174628
16 years ago
16 years ago

People

(Reporter: Kai Ensenbach, Assigned: Alexandru Savulov)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Use test account: login=mozilla password=bugzilla ], URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.1) Gecko/20020826

When you use the steps to reproduce it it's reproducable every time but in other
cases it is not reproducable. In normal case, for example when I use no special
sign, I get the stats of the player or in other Browsers like Konquerer even
with the special sign.

Reproducible: Always

Steps to Reproduce:
1.When you go on "Spielersuche" an you type a nick with a special sign like
yoursweet666© the parameter gets lost.

Actual Results:  
I get the failure that I am not logged in correctly. The problem is definitly
not at the script of the page. Every other Browser gives the right result!

Expected Results:  
It should show the stats of the player!

the configuration of my OS is normal and I am using the default theme "Modern"!

Comment 1

16 years ago
Character-handling in the browser; not a JS Engine issue.

Don't know if this should go to Form Submission, International, 
or DOM. Let's reassign to Form Submission as a guess.

Kai:

I can't find "Spielersuche" on the first page at http://www.chaopoly.de.
Do we need a login to see the bug? If so, could you create a test ID and 
password at this site, say:

                Login    = mozilla
                Password = bugzilla


Thanks -
Assignee: rogerl → alexsavulov
Component: JavaScript Engine → Form Submission
QA Contact: pschwartau → vladimire
(Reporter)

Comment 2

16 years ago
you are right. The account is created now!
Account: mozilla
password: bugzilla

Comment 3

16 years ago
Kai: thanks!

I was able to log in successfully. The next page I came to had the 
"Spielersuche" textbox at the lower right. I entered "yoursweet666©"
into the "Spielersuche" textbox and hit the "Go!" button. 

Confirming bug with Mozilla trunk binary 20021015xx on WinNT.
just as Kai reports, I got a child window saying (in German)
that I was not properly logged on.

After this failure, I looked at the source of some of the HTML:

<script language="JavaScript">

openProfile();

function openProfile()
{  
Profile=window.open("profile.php?name=yoursweet666©&id=1615&sess_id=1127074598
&aktion=answer&game=0&opt=online","Profil","toolbar=0,location=0,status=0,menuba
r=0,scrollbars=1,resizable=0,width=400,height=400");

Profile.moveTo(100,50); }

</script>


We can see the string "yoursweet666©" is part of the URL used in a
call to window.open(), which gets called immediately via openProfile().

Perhaps that's where the bug is triggered. In which case, is this 
related to the recent window.open() bug involving special characters?

bug 174628 
using the window.open(<uri>,''), '&' character gets replaced by '%26 ' string
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [Use test account: login=mozilla password=bugzilla ]

Comment 4

16 years ago
Created attachment 103076 [details]
Text source of frame containing "Spielersuche"

Comment 5

16 years ago
If I save the source in Attachment #4 [details] [diff] locally and try to open it, 
it tries to do the window.open() we saw in Comment #3. Mozilla
brings up the alert shown below saying it can't find the file:

Profile=window.open("profile.php?name=yoursweet666©&id=1615&sess_id=   etc. )

ALERT: "The file /C:/profile.php?name=yoursweet666%A9%26id%3D1615%26se
cannot be found. Please check the location and try again"


The point is not that it can't find the file, but the behavior of the
URL string after the '©' sign is escaped to '%A9'. This is exactly what's
happening in bug 174628, but I can't tell if that's what's causing 
the problem in this bug, too -
(Assignee)

Comment 6

16 years ago
see http://bugzilla.mozilla.org/show_bug.cgi?id=174628#c10 about possible dup.

Comment 7

16 years ago
Yep, duplicate, this is the url its trying to open. 
http://www.chaosonline.de/chaopoly/profile.php?name=yoursweet666%A9%20%26id%3D%26sess_id%3D%26aktion%3Danswer%26game%3D0%26opt%3Donline
Notice all the %26 between name value pairs. 

*** This bug has been marked as a duplicate of 174628 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.