Images from a blocked site can still be saved to disk

VERIFIED DUPLICATE of bug 94118

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 94118
16 years ago
15 years ago

People

(Reporter: Allah the grate, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021014 Phoenix/0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021014 Phoenix/0.3

When you block images from a site, the user cn still save them to disk and
access them.

Reproducible: Always

Steps to Reproduce:
1. Block a site (right click on any image and select "Block Images from this
Server")
2. Refresh the page -- all images disappear and are replaced with blank placeholders
3. Right-click on any of these blank placeholders, and select "Save Link As..." 

Actual Results:  
The "forbidden" image is downloaded to disk and then freely accessible.

Expected Results:  
The image should be unavailable for download. Simplest solution would probably
be that "Save Link As..." be disabled.

Comment 1

16 years ago
OTOH: One could argue that this is a "feature". It allows you to save an image
that you would otherwise not be able to see.

Of course, this isn't good if your intention is to stop your kids from watching
porno.

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 94118 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

16 years ago
To answer David's comment and to be honest, "not-for-my-kids" was basically the
idea. Now for this argument to be valid, such site-blocking preferences should
be password-protected, which they are not. The other issue is that these image
are downloaded *anyway* and simply prevented from being displayed, which is not
good for a modem user who would like to prevent big images from specific sites
in order to preserve surfing comfort. I think this image-blocking thing should
be definitely re-thought and redesigned.

Comment 4

15 years ago
Mass verifiying of old duplicates.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.