Closed Bug 1747087 Opened 3 years ago Closed 3 years ago

nojit-debug link failure for lowerWasmCompareAndSelect (was: Undefined symbol Compare11CompareType on SPARC)

Categories

(Core :: JavaScript: WebAssembly, defect, P3)

defect

Tracking

()

RESOLVED FIXED
97 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox95 --- unaffected
firefox96 --- unaffected
firefox97 --- fixed

People

(Reporter: petr.sumbera, Assigned: lth)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Steps to reproduce:

Solaris SPARC build fails:

60:36.57 Undefined                      first referenced
60:36.57  symbol                            in file
60:36.57 _ZN2js3jit18LIRGeneratorShared25lowerWasmCompareAndSelectEPNS0_11MWasmSelectEPNS0_11MDefinitionES5_NS0_8MCompare11CompareTypeE4JSOp ../build/libjs_static.a(Unified_cpp_js_src_jit7.o)  (symbol scope specifies local binding)
60:36.57 ld: fatal: symbol referencing errors
60:37.45 collect2: error: ld returned 1 exit status

The first bad revision is:
changeset: 602419:d3f99095b5a7
user: Julian Seward <jseward@acm.org>
date: Fri Dec 17 06:18:42 2021 -0800
description:
Bug 1716580 - ARM64+x64: Generate good code for i64 compare-and-select. r=lth.

Keywords: regression
Regressed by: 1716580
Has Regression Range: --- → yes

And yes, there is no JIT support for SPARC.

(In reply to Petr Sumbera from comment #1)

And yes, there is no JIT support for SPARC.

OK, still weird, as in that case the "none" code should have taken care of this. Anyway, patches welcome, I'm happy to review + land.

Severity: -- → S2
Status: UNCONFIRMED → NEW
Component: Untriaged → Javascript: WebAssembly
Ever confirmed: true
Priority: -- → P3
Product: Firefox → Core

Set release status flags based on info from the regressing bug 1716580

This is unlikely to be S2 with Sparc not being a Tier1/2 platform.

Severity: S2 → S3
Assignee: nobody → lhansen
Status: NEW → ASSIGNED

This stub should have been defined when the select optimization
landed.

The missing stub does not make nojit builds fail on CI because those
builds run with --enable-optimize, which strips out the entire
compiler. Whether that is a bug or not is debatable, but I'm adding a
nojit-debug spidermonkey target.

Depends on D134618

Summary: Undefined symbol Compare11CompareType on SPARC → nojit-debug link failure for lowerWasmCompareAndSelect (was: Undefined symbol Compare11CompareType on SPARC)
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 97 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: