Closed Bug 1747575 Opened 3 years ago Closed 3 years ago

ESC key doesn't cancel out Ctrl+E in a New Window

Categories

(Firefox :: Address Bar, defect, P3)

Firefox 95
Desktop
All
defect
Points:
3

Tracking

()

VERIFIED FIXED
98 Branch
Iteration:
97.3 - Jan 3 - Jan 9
Tracking Status
firefox-esr91 --- unaffected
firefox95 --- wontfix
firefox96 --- verified
firefox97 --- verified
firefox98 --- verified

People

(Reporter: zxggoedp, Assigned: adw)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Steps to reproduce:

Press Ctrl+E
Hit ESC

Actual results:

Nothing happens. You're still in the 'search with a search engine' mode. Search engine's name stays in the URL field.

Expected results:

You exit the 'search with a search engine' mode & go to the 'if it's a link you go to the website, or you search with a search engine' mode. Search engine's name goes away from the URL field.

Component: Untriaged → Search
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Summary: ESC key doesn't cancel out Ctrl+E → ESC key doesn't cancel out Ctrl+E in a New Window

Managed to reproduce the issue on Windows 10 x64.

Severity: -- → S4
Status: UNCONFIRMED → NEW
Ever confirmed: true

Hello. This is actually the intended behavior since the introduction of the new design for search. The first press of the 'ESC' key actually dismisses the drop-down of the address bar and the second press of the 'ESC' key will dismiss the one'off engine.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
Component: Search → Address Bar
Priority: -- → P3
Priority: P3 → --

Re-opening the issue. Upon further investigation it looks like the bug IS happening, but only if the user doesn't have any interaction with the address bar before e.g. no clicks inside the bar, or no text input.
Mozregression returned the following pushlog as being the problem here:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=f527b152b687694aea2aba0710729aa472ede3cf&tochange=904db8e18e53be836d984c7c99ff6559f323b044

@Drew can you please have a look as I suspect bug 1723158 might be the issue here.

Status: RESOLVED → REOPENED
Flags: needinfo?(adw)
Resolution: INVALID → ---

Thanks Cristian. Backspace doesn't work either.

Assignee: nobody → adw
Severity: S4 → S3
Status: REOPENED → ASSIGNED
Iteration: --- → 97.3 - Jan 3 - Jan 10
Points: --- → 3
Flags: needinfo?(adw)
OS: Windows 10 → All
Priority: -- → P3
Hardware: x86_64 → Desktop

Confirming bug 1723158 as the regressing bug, the problem is here: https://hg.mozilla.org/mozilla-central/rev/904db8e18e53#l4.17

Regressed by: 1723158
Has Regression Range: --- → yes

This is a regression from bug 1723158, specifically this change.

this._queryContext is undefined in the view in new windows. If you press the
key shortcut to enter search mode immediately in a new window, search mode is
entered without running a query. Then if you hit Escape or Backspace, we hit the
allowEmptySelection getter and throw an error because this._queryContext is
undefined but we're trying to destructure it. This bug does not happen if you
first focus the urlbar and then enter search mode because focusing the urlbar
causes the top-sites query to run.

Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9140d44c1498
Fix a bug that prevents search mode from being exited in new windows. r=harry
Flags: qe-verify+
Flags: in-testsuite+

Comment on attachment 9258437 [details]
Bug 1747575 - Fix a bug that prevents search mode from being exited in new windows.

Beta/Release Uplift Approval Request

  • User impact if declined: This is a simple one-line fix that we should ship sooner rather than later.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Please see bug comments
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): One-line fix to a JS error, has a test.
  • String changes made/needed:
Attachment #9258437 - Flags: approval-mozilla-beta?
Status: ASSIGNED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 98 Branch

(In reply to Drew Willcoxon :adw from comment #9)

  • User impact if declined: This is a simple one-line fix that we should ship sooner rather than later.

I guess we should leave this on the radar for 96 too then.

Comment on attachment 9258437 [details]
Bug 1747575 - Fix a bug that prevents search mode from being exited in new windows.

Approved for 97.0b3.

Attachment #9258437 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment on attachment 9258437 [details]
Bug 1747575 - Fix a bug that prevents search mode from being exited in new windows.

Beta/Release Uplift Approval Request

  • User impact if declined: This would be a nice-to-have ride-along on any 96 dot release.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Please see bug comments
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): One-line fix to a JS error, has a test.
  • String changes made/needed:
Attachment #9258437 - Flags: approval-mozilla-release?
QA Whiteboard: [qa-triaged]

This is verified fixed using Fx98.0a1 and Fx97.0b3 on Windows 10. The ESC key hit now correctly dismisses the address bar and eventually the search mode (on second press). Backspace now correctly removes the engine from the search mode.

Please note that this hasn't made it in the first dot release of 96.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

Comment on attachment 9258437 [details]
Bug 1747575 - Fix a bug that prevents search mode from being exited in new windows.

Approved by 96.0.2

Attachment #9258437 - Flags: approval-mozilla-release? → approval-mozilla-release+

The issue is verified fixed using Fx96.0.2 on Windows 10. The search mode can be correctly dismissed using either ESC or BACKSPACE keys.

You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: