Closed Bug 1750237 Opened 4 months ago Closed 4 months ago

Firefox crashes when a dropdown is too long

Categories

(Core :: Widget: Gtk, defect)

Firefox 96
defect

Tracking

()

RESOLVED DUPLICATE of bug 1746812

People

(Reporter: hugo, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:96.0) Gecko/20100101 Firefox/96.0

Steps to reproduce:

Open any drop-down menu which is too long.

One option is to create A LOT of containers, right click on a link, and then pick "Open Link in new Container Tab". Make sure you have over 80 (I programatically create them, so often have over 100).

Another option is having all the language packs installed, and trying to change the spell checker language. This can be quickly reproduce by running:

flatpak run --nosocket=x11 org.mozilla.firefox --no-remote https://www.deepl.com/translator

Then right click on the large textarea, click on languages, and it should crash. If it doesn't crash the first time, try a second time.

It seems to only happen on the wayland backend (hence the --nosocket=x11 in the above example). Setting MOZ_ENABLE_WAYLAND=1 also works.

I can reproduce this on the Flatpak build, and on the builds from ArchLinux's packages, so I'm guessing it's not at all related to flatpak. Those just seemed easy repro steps, since that version includes enough language packs for the dropdown to be too long.

This WAS NOT an issue a few releases back. I think it was introduced in Firefox 95.

Actual results:

Firefox crashes.

Expected results:

Dropdown should render normally.

The Bugbug bot thinks this bug should belong to the 'Core::Widget: Gtk' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core
Keywords: crash
Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1746812
You need to log in before you can comment on or make changes to this bug.