FreeBSD: mozilla fails to bring up main window

VERIFIED DUPLICATE of bug 14676

Status

SeaMonkey
Build Config
P3
normal
VERIFIED DUPLICATE of bug 14676
18 years ago
13 years ago

People

(Reporter: pete collins, Assigned: Jon Granrose)

Tracking

Trunk
x86
FreeBSD

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
CSSLoader::LoadAgentSheet - failed to get converter stream
*** open of resource:/res/ua.css failed: error=80500001
Warning: Factory creation failed: 'NS_SUCCEEDED(rv)', file
nsNativeComponentLoader.cpp, line 166
Got the event queue from the service
Calling gdk_input_add with event queue


-------------------------------------
STACK TRACE
-------------------------------------
(gdb) cont
Continuing.
initialized appshell
GFX: dpi=100 t2p=0.0694444 p2t=14.4 depth=16
Using '/D/MOZILLA/mozilla/dist/bin' as the resource: base
CSSLoader::LoadAgentSheet - failed to get converter stream
*** open of resource:/res/ua.css failed: error=80500001
Warning: Factory creation failed: 'NS_SUCCEEDED(rv)', file
nsNativeComponentLoader.cpp, line 166
Got the event queue from the service
Calling gdk_input_add with event queue

cont
^C
Program received signal SIGINT, Interrupt.
0x284548e0 in _thread_sys_select () from /usr/lib/libc_r.so.3
(gdb)

Updated

18 years ago
Assignee: leger → granrose
Component: Browser-General → Build Config
QA Contact: leger → cyeh

Comment 1

18 years ago
granrose...is Free BSD supported yet?
(Assignee)

Comment 2

18 years ago
Well, I'm not supporting it... ;-)  I don't know anyone who's working on
FreeBSD, but looking at the SeaMonkey-Ports tinderbox page,
daeron@shadowmere.student.utwente.nl has a tinderbox running FreeBSD that
appears to be working.  So I'll add them to the cc list to see if they have any
input on this crash.

Comment 3

18 years ago
Well ... I am writing this message from within Mozilla built on
FreeBSD-4.0-CURRENT as of November 9th.

I would say .. it runs just fine here ...
(Reporter)

Comment 4

18 years ago
cool, i have been building sucessfully on FreeBSD 3.2 and 3.3
but still having trouble running apprunner and viewer

nothing but core dumps at the profile setup stage.
rm -rf ~/.mozilla/ doesn't do it anymore.

I am going to kill my tree and start again fresh in case there are some lerkers
floating around.

on the 3.3 box i am using gcc295 the new version of egcs compiler suite.

any magic you can share with us would be great for i get alot of email from
other FreeBSD'ers who are also trying to run apprunner on 3.3.

thanks

pete
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Assignee)

Comment 5

18 years ago
I'm going to close this bug to get it off the radar, but you can still update it
with any additional info, or share info on netscape.public.mozilla.builds or
netscape.public.mozilla.unix.

Updated

18 years ago
Status: RESOLVED → REOPENED

Comment 6

18 years ago
Ok ... as of a few days (after fixing up my Tinderbox build to test for
mozilla-bin instead of apprunner) and cleaning out my CVS-tree first to avoid
stale files. Mozilla (formerly known as apprunner) no longer fires up the main
GUI.

The console logs stop at the following lines and mozilla-bin just eats up 100%
CPU and just doesn nothing else:

Start reading in bookmarks.html
Finished reading in bookmarks.html  (246195 microseconds)
Note: verifyreflow is disabled
Successfully created instance of session history
Setting content window
browser.startup.page = 1
startpage = www.mozilla.org
failed to set the page title.


Mozilla just stays silent from here ....

Updated

18 years ago
Resolution: INVALID → ---
Target Milestone: M14

Comment 7

18 years ago
Clearing INVALID resolution due to reopen.

Updated

18 years ago
Summary: apprunner doesn't run and it has been quite some time → FreeBSD: mozilla fails to bring up main window

Updated

18 years ago
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 8

18 years ago
Most certainly a dupe of bug 14676.

*** This bug has been marked as a duplicate of 14676 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 9

18 years ago
Marked verified as a duplicate after checking both. This is clearly the same
FreeBSD bug.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.