Closed Bug 175110 Opened 22 years ago Closed 21 years ago

Copied text now styled in "Geneva 12"

Categories

(Core :: XUL, defect)

PowerPC
Mac System 9.x
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 79864

People

(Reporter: joseph, Assigned: jag+mozilla)

Details

In Mozilla 1.2b / Mac OS 9.1 (2002101612), all copied text is now styled in
Geneva 12.  Previous builds of Mozilla copied text as "plain", which is (IMHO)
the correct behaviour.  Mac OS X versions of Mozilla may not have this bug.

Tried a few recent nightlies and they had this bug too.  It wasn't there in 1.1.

To recreate:

1. Select some text and copy it.  Could be document content, field content, HTML
source...

2. Go to the Finder and choose "Show Clipboard" from the Edit Menu.  You should
see "STYLED TEXT" listed as the clipboard contents.  Optionally, paste your
content into a text editor that can handle rich styles (like SimpleText) to
verify that the font & size are stuck as Geneva 12.  

Why is this bad?  Because Mozilla's arbitrary font style will override any other
application settings.  Pasting "plain" text (simply noted as "TEXT" in the
clipboard contents) will respect the current typeface & size, but "styled" text
will override it.  This means that I have to "style-down" any pasted text into
another application, a needless two-step process.

This bug can also be seen by dragging text into a text clipping.
I believe there was a bug with garbage non-ASCII content in the Mac OS X
clipboard, and the solution was to put styled text in the clipboard. Didn't know
this carried over to the legacy OS:es as well...

Anyway, the normal clipboard behavior is to copy style as well, although Mozilla
seems to put an arbitrary style there. BBEdit copies font and size, but not
color. Mozilla just adds a style to raw content.
dupe of bug 79864

*** This bug has been marked as a duplicate of 79864 ***
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.