All users were logged out of Bugzilla on October 13th, 2018

Complex frames/framesets does not work in V1.01 upwards

RESOLVED FIXED in Future

Status

()

P2
major
RESOLVED FIXED
16 years ago
2 months ago

People

(Reporter: cdeswart, Assigned: john)

Tracking

({testcase})

Trunk
Future
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
complex frames/framsets does not work properly from version 1.01 upto and
including version 1.2b. This includes Linux, Windows and OS/2. 

This used to work in versions before 1.01. The bug is also reproduced in the
latest IBM webbrowser and also Phoenix
(Reporter)

Comment 1

16 years ago
Created attachment 103303 [details]
Frameset testcase that works in IE and Mozilla 1.0.0 but not in 1.0.1 upwards
To reproduce, save the testcase zipfile, unzip it, rename "Test.html" to
"test.html" so it actually works, then open up 0.html.  Notice the blank space
in the bottom right.  Load 1.html (loaded by 0.html).  Notice the same problem.
 Load 2.html (loaded by 1.html).  Now the bottom right shows CNN.  So the bug is
that 0.html and 1.html do not show the CNN page...

This is due to our limit on the frame-nesting depth (see bug 126466 and bug 8065
for motivation/discussion/patches).  There's no good solution here,
unfortunately....
Assignee: asa → jkeiser
Status: UNCONFIRMED → NEW
Component: Browser-General → HTMLFrames
Ever confirmed: true
QA Contact: asa → amar

Comment 3

16 years ago
any idea why they picked 8?

That seems awfully low.

Comment 4

16 years ago
*** Bug 175227 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Priority: -- → P2

Updated

16 years ago
Target Milestone: --- → Future

Comment 6

16 years ago
Created attachment 108414 [details] [diff] [review]
Remove code that limits nested frames

Since we limit the total number of docshells, we shouldn't need to limit nested
frames.

Updated

16 years ago
Attachment #108414 - Flags: review?(jkeiser)

Comment 7

16 years ago
This code was put in there to catch runaway JS and other bustage. 8 frames deep
was  picked as cutoff to catch such content but leave sane content alone. See
also bug 136580.

Where is the limit on the number of docshells that makes this code obsolete?

Comment 8

16 years ago
I had this chat with jkeiser on the IRC and he swore it was there.
(Assignee)

Updated

16 years ago
Attachment #108414 - Flags: review?(jkeiser) → review+

Comment 9

16 years ago
John, where is this max docshell limit that makes it okay to remove this nesting
check? I had a search for 'max' in nsDocShell.cpp & nsWebShell.cpp and didn't
see anything relevant.
(Assignee)

Comment 10

16 years ago
The limit is right there next to the nested frames code.  #define
MAX_NUMBER_DOCSHELLS 100

http://lxr.mozilla.org/mozilla/source/content/base/src/nsFrameLoader.cpp#76
(Assignee)

Updated

16 years ago
Attachment #108414 - Flags: superreview?(jst)
Comment on attachment 108414 [details] [diff] [review]
Remove code that limits nested frames

I never liked this limit in the first place, so I'm glad to see it go.

sr=jst
Attachment #108414 - Flags: superreview?(jst) → superreview+
(Assignee)

Comment 12

16 years ago
Fix checked in.  Does this need to be in 1.0?  If so, please go through the
approval process and such.  It doesn't seem important enough to me, but I'm not
the one with the customer who wants it :)

Updated

16 years ago
Keywords: testcase
This is fixed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Updated

2 months ago
Product: Core → Core Graveyard
Component: Layout: HTML Frames → Layout: Images
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.