Closed Bug 1752494 (egl-linux-vaapi-nightly) Opened 5 months ago Closed 1 month ago

Enable VA-API by default in nightly

Categories

(Core :: Audio/Video: Playback, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
103 Branch
Tracking Status
firefox103 --- fixed

People

(Reporter: stransky, Assigned: stransky)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(1 file)

If we want to enable VA-API by default we need to (at least):

  • specify supported hardware and enable it only there
  • make sure we fallback to SW decode if there's any problem
No longer depends on: 1751991
Depends on: 1752497

With Bug 1751363 fixed we may consider to enable it by default for Mesa/Intel/AMD users in Nightly/Beta.

Summary: Enable VA-API by default → Enable VA-API by default in nightly/beta
Depends on: 1765350

Maybe these as well?

bug 1771382

  • The user has dual Intel/Nvidia (Optimus): Nvidia is disabled in BIOS, Intel is shown as the only graphics card.
  • /usr/share/glvnd/egl_vendor.d/50_mesa.json and 10_nvidia.json exist, libglvnd prefers the lower number. The Nvidia driver is tried in RDD process and it crashes due to the sandbox. Too many RDD crashes at once cause a main process crash ([@ mozilla::PRDDChild::OtherPid ]).
  • Even if the RDD sandbox would allow the Nvidia driver, it still might not reliably fall back to Mesa (bug 1745172), hopefully already handled by bug 1724385.

bug 1758473

  • Main process crash if VAAPIIsSupported hits vdpau_drv_video.so,
    which calls XDisplayString(driver_data->x11_dpy), but vaGetDisplayDRM() doesn't fill ->x11_dpy.

I think Mesa & Intel/AMD excludes any NVIDIA hardware (Bug 1758473).
Bug 1771382 is about fatal system misconfiguration which affects all GL applications, I don't think we can do anything here.

Intel is shown as the only graphics card.

My point was: How do you want to be sure that Nvidia hardware & driver are not involved?
What is the "fatal system misconfiguration"? "Having the Nvidia driver installed" or "disabling Nvidia in BIOS"?

(In reply to Darkspirit from comment #4)

Intel is shown as the only graphics card.

My point was: How do you want to be sure that Nvidia hardware & driver are not involved?
What is the "fatal system misconfiguration"? "Having the Nvidia driver installed"?

In Bug 1758473 NVIDIA is detected so we can disable VA-API.
Bug 1771382 is caused by wrong/incomplete NVIDIA binary drivers uninstall. It turns your box to broken state and we can't anything about it. I experienced that once by myself.

Good argument, thanks! Please proceed. :)
Verified: In case of problems, VAAPI can be force-disabled by setting media.hardware-video-decoding.enabled to false.

Summary: Enable VA-API by default in nightly/beta → Enable VA-API by default in nightly
Assignee: nobody → stransky
Status: NEW → ASSIGNED
Alias: gl-linux-vaapi-nightly
Alias: gl-linux-vaapi-nightly → egl-linux-vaapi-nightly
Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/a13b95f4fd43
[Linux] Enable VA-API on Nightly and Mesa >= 21.0 r=aosmond
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 103 Branch

Martin, do we want to mention that change in out 103 nightly release notes?
https://wiki.mozilla.org/Release_Management/Release_Notes#Nomination_in_Bugzilla

Flags: needinfo?(stransky)

(In reply to Pascal Chevrel:pascalc from comment #10)

Martin, do we want to mention that change in out 103 nightly release notes?
https://wiki.mozilla.org/Release_Management/Release_Notes#Nomination_in_Bugzilla

Yes, that would be great.

Flags: needinfo?(stransky)

Release Note Request (optional, but appreciated)
[Why is this notable]: Firefox enables hardware video decoding on Linux by default. It's used on Intel/AMD platform when VA-API is available.
[Affects Firefox for Android]: no
[Suggested wording]:
[Links (documentation, blog post, etc)]:

relnote-firefox: --- → ?

Note added to 103 nightly release notes

Clearing the relnote flag since this will not be added to the 103 release notes in beta/release

relnote-firefox: ? → ---
Regressions: 1777200
You need to log in before you can comment on or make changes to this bug.