Closed Bug 1752734 Opened 4 months ago Closed 2 months ago

Full page screenshots are scaled down without warning

Categories

(Firefox :: Screenshots, defect, P3)

Firefox 96
Desktop
All
defect

Tracking

()

VERIFIED FIXED
101 Branch
Tracking Status
firefox96 --- wontfix
firefox97 --- wontfix
firefox98 --- wontfix
firefox99 --- wontfix
firefox100 --- wontfix
firefox101 --- verified

People

(Reporter: heavymetal, Assigned: niklas)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:96.0) Gecko/20100101 Firefox/96.0

Steps to reproduce:

Take a full page screenshot in Firefox on Windows or Linux desktop with Firefox' builtin screenshot tool.

Actual results:

Image is scaled down to 2552 px width, and it's scaled down BADLY without any antialiasing. Whole table lines are dropped because of their 1 px width, that type of "scaling" simply doesn't work for websites.

Expected results:

Full page screenshots should NEVER get scaled down, they should capture unscaled images as the screenshot tools does for "visible area only".
At least there should be a big fat warning that the screenshot just taken will probably be useless.

The Bugbug bot thinks this bug should belong to the 'Firefox::Screenshots' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Screenshots

Could you please provide a screenshot with what you are facing just to make it easier for me to understand the issue?
Thanks.

Flags: needinfo?(heavymetal)
Flags: needinfo?(heavymetal)

Both screenshots taken from the same Bugzilla page.
Full page is automatically scaled down and some horizontal lines are dropped.
Visible area screenshot is not scaled down.

I just noticed: When opening these files in Firefox, they both get zoomed in. The downscaled "full" screenshot (2560 px) shows as fullscreen on my 3840 px screen, the "visible area" screenshot (3840 px) is presented at zoom level 66% to fill the screen, zooming in to 100% makes the image too large to fit on the screen.
So maybe a scaling issue caused by the environment's dpi setting?
I think screenshots should always reflect the actual screen rendering, at least they should scale consistently for full and partial screenshots.
Thanks for taking a look at the issue.

Managed to reproduce this issue on Windows 10 x64 and on Ubuntu 20.04 x64.

Severity: -- → S3
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → Desktop

Hey Hani, can you share the device pixel ratio and screen resolution of the devices you were able to reproduce this on?

Flags: needinfo?(hani.yacoub)

Pixel ratio: 16:9
Screen resolution: 1920 x 1080

Please let me know if I can help with other info.

Flags: needinfo?(hani.yacoub)

(In reply to Hani Yacoub from comment #8)

Pixel ratio: 16:9

We actually need the value of window.devicePixelRatio from your devtools console. I should be 1 for a regular display and > 1 for high-pixel-density displays. Also, can you check your OS scaling settings - are those at 100% or more?

Flags: needinfo?(hani.yacoub)

My screen is 3840x2160, window.devicePixelRatio is 1.5 in both Windows and Linux, default zoom in Firefox is 100%.

In Linux, environment is set to 160 dpi via parameter Xft.dpi in ~/.Xresources, because Firefox ignores the correct dpi setting recognized by the X Server (as verified via xdpyinfo).

In Windows, display scaling is set to 150%.

On Windows:
Screen resolution: 1920 x 1080
Pixel ratio: 1.25
Scaling is 125% (Recommended)
On Ubuntu:
Screen resolution: 1920x1080 (16:9)
Pixel ration: 1
Scale: 100%

Flags: needinfo?(hani.yacoub)

In the past reducing file size was a constraint Screenshots needed to work with, I think now that screenshots is entirely client-side, people should get what they see and can downsize afterwards if they need to.

Assignee: nobody → nbaumgardner
Status: NEW → ASSIGNED
Priority: -- → P3
Pushed by sfoster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/41e0f33c8e12
Remove scaling down of full page screenshots. r=sfoster
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 101 Branch
Duplicate of this bug: 1744269

The patch landed in nightly and beta is affected.
:niklas, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(nbaumgardner)
Flags: needinfo?(nbaumgardner)
Flags: qe-verify+

I managed to reproduce this on Firefox 100.0(20220428192727) on Win10 64-bits. Verified as fixed on Firefox 101.0b7(20220515185854), Nightly 102.0a1(20220515214519) on Win10 64-bits, Ubuntu 20.04 and macOS 11.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.