If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Folder indicator missing in "Mail" folder list and in "Preferences ..." when subfolders exist

VERIFIED DUPLICATE of bug 174831

Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 174831
15 years ago
13 years ago

People

(Reporter: Karl Scriba, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016

Mail and newsgroup folders that had subfolders used to have an right pointing,
arrow shaped indicator to the left of the parent folder.  This was the case with
Mozilla 1.2a and earlier, but is not the case with Mozilla 1.2b

Double-clicking a parent folder to the left of the folder name (where the arrow
shaped indicator used to be) will expand the subfolders and make them
accessible.  Determining which folders have subfolders turns into a guessing or
a trial and error game.

Once a parent folder has been expanded, a downwards pointing arrow appears to
the left of the parent folder's name, where it is expected and where the right
pointing arrow should have been when the parent folder was not expanded.

The same problem can be seen when trying to navigate the "Preferences ..." dialogue.

Reproducible: Always

Steps to Reproduce:
1. Install Mozilla 1.2b
2. Either open the Mail & Newsgroups window or select the "Edit -> Preferences
..." menu option. In the Mail & Newsgroups window, the mail and news account
folders will show subfolders, but when the list is collapsed, the right
pointing, arrow shaped indicator is not displayed.
3. Click to the left of a folder name.  If the folder has subfolders, the list
will expand to show them, as well as a downward pointing arrow shaped indicator.
4. Click to the left of the same folder name, and the list will be collapsed
without displaying any subfolder indicators.
Actual Results:  
Clicking to the left of the folder name of an expanded folder will collapse the
list of subfolders without displaying any subfolder indicators to the left of
the collapsed parent folder.

Expected Results:  
The right pointing, arrow shaped indicator should be displayed to the left of a
parent folder to indicate subfolders.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 174831 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
marking verified as a duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.