Closed Bug 1754346 Opened 8 months ago Closed 25 days ago

Pages are restored after restart despite settings and about:config tweaks.

Categories

(Toolkit :: Data Sanitization, defect)

Firefox 96
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: completetrash.ryfft, Unassigned)

Details

Steps to reproduce:

Configure the following in Settings:

  • Uncheck "Open previous windows and tabs"
  • Check "Delete cookies and site data when Firefox is closed"
  • Check "Clear history when Firefox closes"

Configure the following in about:config -

  • browser.sessionstore.resume_from_crash = false
  • browser.sessionstore.resume_session_once = false
  • browser.sessionstore.max_resumed_crashes = 0

Open a bunch of pages, including ones that require log in.

Restart computer.

Open Firefox.

Actual results:

All the pages from my previous session are restored, included the current state of logged in pages.

Expected results:

No pages should have been restored whatsoever.

This seems like a serious issue for people with privacy concerns. It has happened to me on Linux (Debian 12, PopOS), Windows 11 and macOS. I have all possible settings enabled that should be preventing any sort of session restore and Firefox is still restoring my pages if I restart the computer without first closing Firefox.

The Bugbug bot thinks this bug should belong to the 'Toolkit::Data Sanitization' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Data Sanitization
Product: Firefox → Toolkit

Thanks for filing a bug! Following your STR I cannot reproduce the issue on Firefox Nightly 99.0a1 (2022-02-14) (64-bit) on Ubuntu 21.10 and Windows 10. Firefox does not show the about:sessionrestore page and also does not open any of the previous tabs.

A few questions for you to further diagnose the issue:

  • Can you reproduce the issue using Firefox Nightly?
  • Are the tabs restored directly after startup of Firefox, or do you see the about:sessionrestore page first?
  • Does about:crashes list any recent crashes roughly matching your restart time? If so, could you please submit them and link them here?
  • Could you share your data from about:support? If you prefer to not share it here you can also send me an email: pbz@mozilla.com
Flags: needinfo?(completetrash.ryfft)

No reply from reporter. Closing.

Status: UNCONFIRMED → RESOLVED
Closed: 25 days ago
Flags: needinfo?(completetrash.ryfft)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.