Closed Bug 1754542 Opened 6 months ago Closed 6 months ago

Always ask you where to save files setting does not work - update 98.0b2 (64-bit)

Categories

(Firefox :: File Handling, defect)

Unspecified
All
defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox97 --- unaffected
firefox98 --- affected
firefox99 --- affected

People

(Reporter: hanscomka, Unassigned)

Details

Attachments

(1 file)

Attached image bug.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:98.0) Gecko/20100101 Firefox/98.0

Steps to reproduce:

Try to download file.

Actual results:

Settings->Downloads (selected) Always ask you where to save files

Does not prompt for location, saves to Settings->Downloads (not selected) Save files to [location]

Expected results:

Should prompt for location to save.

I changed selection/location and it downloads to new location. I changed back to "Always ask" and still just downloads to location. This is since recent update.
(and opens tab with file e.g. file:///PATH/TO/FILE/filename.ext)

I've just discovered it's only doing this for svg files.

Component: Untriaged → Downloads Panel

Hi,

I was able to reproduce the issue on both MacOS and Windows 10 using Firefox Nightly 99.0a1 and Firefox Beta 98.0b9 as well, however it does not occur on Firefox 97.0.

I'll run a mozregression asap in order to try and find out what introduced this issue.

Thank you for reporting!

Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → All
Version: Firefox 98 → Trunk

The pushlog I got from running mozregression is the following: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f16661bf49d3ba3edf454c663f90c7a0959b59e3&tochange=bd494168b95a83344e778b5b4679b67101482118

Apparently Bug 1738916 introduced this, although now I'm not entirely sure if this is an expected result or an issue.

Gijs, can you take a look over this please?

Thanks!

Component: Downloads Panel → File Handling
Flags: needinfo?(gijskruitbosch+bugs)

If you don't want SVGs to always open with Firefox, you can change this in the Firefox Settings. Search for "svg" and in the big list of filetypes (you may need to scroll it) switch SVGs from "Open in Firefox" to "save file" or "always ask". You can also pick an external application to open them with (either the OS default or a custom app).

When files are set to automatically open (in Firefox or another app), this is an expected result. We do this for files set to "always open" to avoid prompting for a location for files that the user is not interested in keeping permanently in a specific location.

This was a change in response to complaints by other Firefox users in bug 1738916 (ie if I've told Firefox to open files of type X to always open immediately, I don't want to be bothered with a question about where to save the file in the meantime - I only want that when I'm saving a file, rather than opening it). This behaviour also matches other browsers, AFAIK, so I don't think we'll want to change it.

(We don't have a "not a bug" resolution so I'm picking "invalid" as the closest value)

Status: NEW → RESOLVED
Closed: 6 months ago
Flags: needinfo?(gijskruitbosch+bugs)
Resolution: --- → INVALID

(We're likely to change the default for SVG files to "save to disk" for 98 still, but that's happening elsewhere, and I guess that might also help with your concern.)

(In reply to :Gijs (he/him) from comment #4)

If you don't want SVGs to always open with Firefox, you can change this in the Firefox Settings. Search for "svg" and in the big list of filetypes (you may need to scroll it) switch SVGs from "Open in Firefox" to "save file" or "always ask". You can also pick an external application to open them with (either the OS default or a custom app).

When files are set to automatically open (in Firefox or another app), this is an expected result. We do this for files set to "always open" to avoid prompting for a location for files that the user is not interested in keeping permanently in a specific location.

This was a change in response to complaints by other Firefox users in bug 1738916 (ie if I've told Firefox to open files of type X to always open immediately, I don't want to be bothered with a question about where to save the file in the meantime - I only want that when I'm saving a file, rather than opening it). This behaviour also matches other browsers, AFAIK, so I don't think we'll want to change it.

(We don't have a "not a bug" resolution so I'm picking "invalid" as the closest value)

So one of your updates changed this setting for mime/file type? I did not. This is reminiscent of IE - which always opens SVG.
This setting does not affect rendering?

(In reply to hanscomka from comment #6)

So one of your updates changed this setting for mime/file type?

Ehhh, sort of. The setting was changed to "open in Firefox" in bug 1639067, but it hasn't "worked" (instead showing a dialog asking you whether to open or save, with "open in firefox" selected by default) because of bug 453455. We addressed that bug with other patches, so now the setting we changed 2 years ago is actually being honoured. This also surprised ourselves a bit, and like I said we are addressing it elsewhere, so the default for the setting is going to change back to "save to disk".

I did not. This is reminiscent of IE - which always opens SVG.

Yep.

This setting does not affect rendering?

No, if the website just contains an SVG, and doesn't send Content-Disposition: attachment, a strange mimetype like application/octet-stream, or use <a href=foo.svg download>Click here</a> to provide a download link or something, then the setting has no effect and we show the image/SVG as usual.

You need to log in before you can comment on or make changes to this bug.