Closed Bug 1754897 Opened 8 months ago Closed 3 months ago

Support Named Scroll Progress Timelines

Categories

(Core :: CSS Transitions and Animations, enhancement, P3)

Unspecified
All
enhancement

Tracking

()

RESOLVED FIXED
103 Branch
Tracking Status
firefox103 --- fixed

People

(Reporter: boris, Assigned: boris)

References

(Blocks 2 open bugs, )

Details

(Keywords: dev-doc-needed)

Attachments

(7 files, 3 obsolete files)

48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review
48 bytes, text/x-phabricator-request
Details | Review

Support the following properties:

  1. scroll-timeline-name longhand property, https://drafts.csswg.org/scroll-animations-1/rewrite#scroll-timeline-name
  2. scroll-timeline-axis longhand property, https://drafts.csswg.org/scroll-animations-1/rewrite#scroll-timeline-axis
  3. scroll-timeline shorthand property, https://drafts.csswg.org/scroll-animations-1/rewrite#scroll-timeline-shorthand
Status: NEW → ASSIGNED
Blocks: 1746094
Summary: Support specific scroll container for source descriptor → Support specific scroll container for scroll progress timeline

Based on the discussion in Matrix, we would like to implement the proposal way because the proposal spec will be finished soon (link: https://drafts.csswg.org/scroll-animations-1/rewrite#scroll-timelines-named)

Blocks: 1733260
No longer blocks: css-scroll-linked-animations, 1737918
Summary: Support specific scroll container for scroll progress timeline → Support Named Scroll Progress Timelines
Attachment #9263836 - Attachment is obsolete: true

There is a spec issue which may block this bug: https://github.com/w3c/csswg-drafts/issues/7047

No longer blocks: 1746094
Keywords: dev-doc-needed
Attachment #9276527 - Attachment description: Bug 1754897 - Part 4: Support named scroll timelines when updating animations. → Bug 1754897 - Part 4: Hook named scroll timelines to animation-timeline.
Attachment #9277217 - Attachment description: Bug 1754897 - Part 5: Update the associated ScrollTimelines during traversal. → Bug 1754897 - Part 5: Update the associated animation timelines if scroll-timeline property gets changed.
Attachment #9277217 - Attachment description: Bug 1754897 - Part 5: Update the associated animation timelines if scroll-timeline property gets changed. → Bug 1754897 - Part 6: Update the associated animation timelines if scroll-timeline property gets changed.

Different types of scrollers may need some special manipulation, e.g. we would
like to look up a ScrollTimeline object which is created by scroll-timeline
property and update its associated animations (in this patch series).

Any we may need to handle some special cases for scroller(nearest) in the
future (e.g. Bug 1765211).

Attachment #9277217 - Attachment description: Bug 1754897 - Part 6: Update the associated animation timelines if scroll-timeline property gets changed. → Bug 1754897 - Part 7: Update animations if the referenced scroll-timeline property gets changed.

It seems we use it frequently, so move it to AnimationUtils.h.

Duplicate of this bug: 1746094
Blocks: 1774060

Comment on attachment 9277217 [details]
Bug 1754897 - Part 7: Update animations if the referenced scroll-timeline property gets changed.

Revision D146754 was moved to bug 1774060. Setting attachment 9277217 [details] to obsolete.

Attachment #9277217 - Attachment is obsolete: true
Attachment #9278961 - Attachment description: Bug 1754897 - Part 8: Factor out the check of PseudoStyleType for animations. → Bug 1754897 - Part 7: Factor out the check of PseudoStyleType for animations.
Pushed by bchiou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/783c84b1fe1d
Part 1: Support scroll-timeline-name longhand in style system. r=emilio
https://hg.mozilla.org/integration/autoland/rev/d545afeeab51
Part 2: Support scroll-timeline-axis longhand in style system. r=emilio
https://hg.mozilla.org/integration/autoland/rev/555e14e928cf
Part 3: Support scroll-timeline shorthand in style system. r=emilio
https://hg.mozilla.org/integration/autoland/rev/b186ae5e1631
Part 4: Hook named scroll timelines to animation-timeline. r=emilio
https://hg.mozilla.org/integration/autoland/rev/b69bf028a316
Part 5: Factor out the creation of ScrollTimeline object. r=emilio
https://hg.mozilla.org/integration/autoland/rev/dc04d44c6184
Part 6: Add Scroller::Type to the HashMap key for ScrollTimeline. r=emilio
https://hg.mozilla.org/integration/autoland/rev/ec99acd78b32
Part 7: Factor out the check of PseudoStyleType for animations. r=emilio
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/34408 for changes under testing/web-platform/tests
Upstream PR merged by moz-wptsync-bot
You need to log in before you can comment on or make changes to this bug.