Closed Bug 1755748 Opened 10 months ago Closed 9 months ago

Captions from background tab Youtube videos in the PiP window are delayed

Categories

(Toolkit :: Picture-in-Picture, defect, P2)

defect
Points:
5

Tracking

()

VERIFIED FIXED
100 Branch
Tracking Status
firefox100 --- verified

People

(Reporter: mtigley, Assigned: niklas)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fidefe-MR1-2022])

Attachments

(1 file)

STR

  1. Enable the pref media.videocontrols.picture-in-picture.display-text-tracks.enabled
  2. Go to a video on Youtube and ensure captions are enabled
  3. Open PiP
  4. Switch to another tab and observe caption text in PiP window

Expected

Caption text should display without delay in PiP window

Actual

There seems to be a delay when displaying captions. This is more obvious when audio is playing. Sometimes the displayed caption seems to be "stuck" until you switch back to the original tab, which allows the captions to "catch-up" with what's shown in the original video.

Severity: -- → S2
Priority: -- → P2
Whiteboard: [fidefe-MR1-2022]

(5 points is a low-confidence estimate; if this is specifically related to the YouTube tab going into a background state, it might be quite difficult to fix)

Points: --- → 5
See Also: → 1757335
See Also: → 1598654
Summary: There seems to be a delay with displaying Youtube captions in the PiP window when on another tab → Captions from background tab Youtube videos in the PiP window are delayed
See Also: 1757335
Assignee: nobody → nbaumgardner
Status: NEW → ASSIGNED
Pushed by nbaumgardner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/93212b85e5b7
Keep PiP tabs in active state. r=mconley,dthayer
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 100 Branch

Issue reproduced in Nightly v99.0a1 from 2022-02-16 on Mac OS 11 and Window 10 and Ubuntu 20. The fix was verified in Nightly v100.0a1 from 2022-03-05 on Windwos 10, Mac OS 11 and Ubuntu 20/22.

Status: RESOLVED → VERIFIED
Blocks: 1598654
See Also: 1598654
Blocks: 1681718
Blocks: 1750629
Regressions: 1783289
You need to log in before you can comment on or make changes to this bug.