URL ending in .png displayed as image despite text/html MIME type

RESOLVED FIXED

Status

SeaMonkey
General
RESOLVED FIXED
15 years ago
12 years ago

People

(Reporter: Brion Vibber, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016

text/html documents whose URLs end in '.png' are put through the image displayer:

http://www.wikipedia.org/wiki/Image%3A101stEagle.png
http://www.wikipedia.org/wiki/Image%3AAnti-aliasing.png
http://www.wikipedia.org/wiki/Image%3APinyinacc.png
etc

title bar: Image%3A101stEagle.png (TEXT/HTML Image) - Mozilla {Build ID: 2002101612}
in pane: The image "http://www.wikipedia.org/wiki/Image%3A101stEagle.png" cannot
be displayed, because it contains errors.

The raw HTML can be seen via 'View source', but I can't figure out a way to get
it to render the page where it sits.

The same document works fine using an alternate URL that relegates the .png to
the query string:
http://www.wikipedia.org/w/wiki.phtml?title=Image%3A101stEagle.png

.jpg and .gif seem to be immune; these work fine:
http://www.wikipedia.org/wiki/Image%3ADubrovnik.jpg
http://www.wikipedia.org/wiki/Image%3ACa-nf.gif
etc

Reproducible: Always

Steps to Reproduce:
1. Go to a URL that ends in .png but actually produces text/html

Actual Results:  
Mozilla complains that the image contains errors. (Of course it's a malformed
image -- it's HTML code, not an image!)

Expected Results:  
Render the HTML document
Do you have quicktime plugin installed?  If so, this is bug 175368
Depends on: 175368
(Reporter)

Comment 2

15 years ago
Yes, looks like the same problem. Fixed in build 2002102108.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.