Closed Bug 1756306 Opened 2 years ago Closed 2 years ago

As a developer, I want the ability to specify local overrides for script files that persist between page loads.

Categories

(DevTools :: Debugger, enhancement)

Firefox 97
enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1704690

People

(Reporter: matthew.orres, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:97.0) Gecko/20100101 Firefox/97.0

Steps to reproduce:

When working on a web application, I want to debug a specific issue in production (and save time), but I cannot edit scripts and have them persist between page loads just for my client. Chrome provides local overrides as a devtools option, and I'd like the same in Firebug.

Actual results:

Firebug/Firefox devtools has no local overrides option.

Expected results:

Add a local overrides option that allows me to save specific changes to a script file and persist that change (and ignore the file downloaded from the server)

Setting a component for this enhancement in order to get the dev team involved.
If you feel it's an incorrect one please feel free to change it to a more appropriate one.

Status: UNCONFIRMED → NEW
Component: Untriaged → Debugger
Ever confirmed: true
Product: Firefox → DevTools
Status: NEW → RESOLVED
Closed: 2 years ago
Duplicate of bug: 1704690
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.