Closed Bug 1760259 Opened 11 months ago Closed 10 months ago

Disable session restore infobar for marionette tests, webplatform tests and geckodriver

Categories

(Testing :: General, task, P2)

Default
task
Points:
1

Tracking

(firefox100 fixed)

RESOLVED FIXED
100 Branch
Tracking Status
firefox100 --- fixed

People

(Reporter: jdescottes, Assigned: jdescottes)

References

Details

(Keywords: perf-alert, Whiteboard: [bidi-m3-mvp])

Attachments

(2 files)

We should set the preference browser.startup.couldRestoreSession.count to -1 for marionette tests, webplatform tests and geckodriver to avoid showing the "restore tabs" info bar.

It can make the viewport smaller than expected which makes automated tests flaky (see Bug 1734034)

(not sure if Testing/General is the right component here, since this impacts several test harness)

Assignee: nobody → jdescottes
Status: NEW → ASSIGNED

If doable it would be good to have this change as part of the next geckodriver 0.31.0 release given that it's not clear how many tests this could badly influence out there.

Blocks: 1723202
Points: --- → 1
Priority: -- → P2
Whiteboard: [bidi-m3-mvp]
No longer blocks: 1723202

We plan to fully handle this in Firefox and this should no longer block geckodriver 0.31.0

Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4c90589f3f7f
[remote] Apply RecommendedPreferences on command-line-startup r=webdriver-reviewers,whimboo
https://hg.mozilla.org/integration/autoland/rev/e4642f25fd37
[remote] Disable session restore infobar for marionette tests, webplatform tests and geckodriver r=webdriver-reviewers,whimboo
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 100 Branch
Regressions: 1763562
Keywords: perf-alert
You need to log in before you can comment on or make changes to this bug.