backspace key works like "back" button

VERIFIED DUPLICATE of bug 108816

Status

()

VERIFIED DUPLICATE of bug 108816
16 years ago
16 years ago

People

(Reporter: allltaken, Assigned: aaronlev)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2b) Gecko/20021016

If the cursor is at the top of the page, or maybe undefined, and the backspace
key is pressed, the browser will go to the previous webpage. Alt+left-arrow is
supposed to do this and is documented. I don't think this action of the
backspace key is intentional. I've noticed window switching or webpage changing
caused by the tab key too. In MS Windows, there are some hotkey commands for
switching windows, and some hotkey actions within Mozilla too. BUT these are
supposed to be combo keys like ctl-u, not single keys. The code that processes
keystrokes might be reviewed to see if something's slipping thru the logic.


Reproducible: Always

Steps to Reproduce:
1.load the first webpage.
2.load another webpage
3. press the backspace key

Actual Results:  
The browser re-displays the first webpage.

Expected Results:  
According to the hotkey info in the menus, it shouldn't have done anything. A
backspace without a keyboard data entry field containing something to erase
should just be thrown away, I think.

Comment 1

16 years ago
->Keyboard Navigation
Assignee: asa → aaronl
Component: Browser-General → Keyboard Navigation
QA Contact: asa → sairuh
(Assignee)

Comment 2

16 years ago
This is for IE keyboard compatibility. We had lots of arguments about this in
the past, but settled on that solution.

Anyway, the final decision's been made and at this point we just want to stay
consistent.

See bug 108816 for reference.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 3

16 years ago
reopening to dupe
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 108816 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.