Closed Bug 1761329 Opened 2 months ago Closed 1 month ago

Breakout rooms with Zoom web client don't show participants video streams on Linux

Categories

(Core :: Canvas: 2D, defect, P3)

Desktop
Linux
defect

Tracking

()

RESOLVED INVALID
Tracking Status
relnote-firefox --- 99+
firefox-esr91 --- unaffected
firefox98 --- disabled
firefox99 --- affected
firefox100 --- affected

People

(Reporter: aosmond, Assigned: aosmond)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

STR:

  1. Create a meeting with the desktop Zoom client, join on another computer with the web client.
  2. Create a breakout room from the desktop client and assign the web client to one.
  3. Note that when the web client joins the breakout room, it cannot see it's self preview.
  4. Join the new breakout room from the desktop client. Note that the web client cannot see the desktop's camera view either.

Ran in a debug build but there was not much in the way of warnings. The web console indicated there was unreachable JS code each time someone joins the breakout room, but not much else to go by either.

This appears to work on OSX/Windows, it is just broke on Linux. Downgrading to a S3 as a result.

Severity: S2 → S3
OS: Unspecified → Linux
Priority: P2 → P3
Hardware: Unspecified → Desktop

This isn't working on two different computers with different cameras/gfx cards. After disabling OffscreenCanvas, rejoining the meeting, the breakout room worked, and after reenabling it, it also worked. So fundamentally all of the pieces seem to be there for this to work, but perhaps there is some race condition, or missing initialization.

Summary: Breakout rooms with Zoom web client don't show participants video streams → Breakout rooms with Zoom web client don't show participants video streams on Linux

A workaround appears to be to join the breakout room, observe the issue, leave the meeting, rejoin the meeting, rejoin the breakout room, and now it works.

Simplified STR:

  1. Host a meeting from the web client. Only the host needs to join. Observe self preview working.
  2. Once started, switch view to gallery mode.
  3. Create breakout room and join it.
  4. Observe there is no self preview.
  5. Leave breakout room.
  6. Observe there is working self preview.
  7. Rejoin breakout room.
  8. Observe there is working self preview.

If I don't do step 2, and leave it as the default view, then the breakout room self preview works in step 4.

From what I have gathered in the logs, we make no attempt to create an OffscreenCanvas object, or WebGL context, during step 3.

Release Note Request (optional, but appreciated)
[Why is this notable]: Gallery mode in the Zoom web client is now accessible in Firefox 99. Display of video is not always working with breakout rooms with gallery mode.
[Affects Firefox for Android]: No. The Zoom web client is not accessible on Android.
[Suggested wording]: When a user of the Zoom web client enters a breakout room, one's self view and of other participants may not appear. Leaving the breakout room and re-entering it should resolve the issue.
[Links (documentation, blog post, etc)]: This bug

relnote-firefox: --- → ?

After discussions with Zoom, they have isolated/fixed the problem on their side. We may need to wait for the fix to be fully deployed. Either way, it is not a bug in Firefox.

Status: NEW → RESOLVED
Closed: 1 month ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.