Closed Bug 1762380 Opened 2 months ago Closed 2 months ago

The PiP Play/Pause button has a border when the PiP window is focused

Categories

(Toolkit :: Picture-in-Picture, defect, P3)

Desktop
Windows
defect

Tracking

()

VERIFIED FIXED
101 Branch
Tracking Status
firefox98 --- wontfix
firefox99 --- wontfix
firefox100 --- wontfix
firefox101 --- verified

People

(Reporter: mheres, Assigned: janvi01)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached image play button.gif

[Affected Versions]:

  • Firefox Release 98.0.2 (Build ID: 20220322144853)
  • Firefox RC 99.0 (Build ID: 20220328190900)
  • Firefox Nightly 100.0a1 (Build ID: 20220330214842)

[Affected Platforms]:

  • Windows 10

[Prerequisites]:

  • Have Firefox open.

[Steps to reproduce]:

  1. Navigate to a page hosting a video (e.g. https://youtu.be/AjWfY7SnMBI)
  2. Click the Picture-in-Picture button.
  3. Observe the Play/Pause button.

[Expected result]:

  • The button does not have a border.

[Actual result]:

  • The button has a border around it, as if it is focused.

[Notes]:

  • [Windows] Clicking outside the PiP window will make it disappear and clicking inside the PiP window will make it be displayed again.
  • [Linux + macOS] The border is no longer displayed if the user clicks either inside or outside the PiP window.
  • Attached is a recording of the issue.

It would be nice to fix it for 100, but definitely not critical and can wait until 101.

Priority: -- → P3

Hey, I would like to work on this.

(In reply to Janvi Bajoria [:janvi01] from comment #2)

Hey, I would like to work on this.

Hi Janvi, I would submit a patch so that Bugzilla can auto-assign you to the bug. Help with this would be greatly appreciated!

I noticed, that the control button autofocus property is set to true which is causing a border around the play/pause button.

Hey, I didn't get why you would submit a patch, I should submit one depicting these changes right?
Thanks!

Assignee: nobody → janvibajo1
Status: NEW → ASSIGNED
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b19863195e7a
removed pip play/pause button border when the pip window is focused r=mconley
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 101 Branch

I have verified that the issue is no longer reproducible. The border is not displayed at all anymore. Tested on Firefox Nightly 101.0a1 (Build ID: 20220406093646) on Windows 10, macOS 11.6 and Linux Mint 20.2.

Status: RESOLVED → VERIFIED

The patch landed in nightly and beta is affected.
:janvi01, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(janvibajo1)
Flags: needinfo?(janvibajo1)

The patch landed in nightly and beta is affected.
:janvi01, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

For clarification, this fix does not require an uplift and can stay in the current Nightly version.

You need to log in before you can comment on or make changes to this bug.