Closed Bug 1762951 Opened 2 years ago Closed 6 months ago

Remove the statuspanel from our tests so they are not captured by visual metrics

Categories

(Testing :: Raptor, task, P2)

task

Tracking

(firefox124 fixed)

RESOLVED FIXED
124 Branch
Tracking Status
firefox124 --- fixed

People

(Reporter: sparky, Assigned: Gijs)

References

Details

(Whiteboard: [fxp][webpagetest])

Attachments

(1 file)

This bug is for removing the tooltip/statuspanel on the bottom-left of the screen. Currently, it always shows up and is then included in the visual-metrics processing.

We should remove this. :gijs mentioned an option for how to get rid of it:

CSS change
Can call this during browsertime tests using proper context
:gijs: the searchfox thing you want for that panel is `statuspanel`

We could run priviledged JS in a browsertime test to hide this CSS class: https://searchfox.org/mozilla-central/source/browser/base/content/browser.css#967

Blocks: 1859492

It was brought up that this is also included in the WebPageTest visual page load analysis. We should consider if there's a fix that will include their results.

Can we just make the viewport a bit smaller to exclude the statuspanel?

(In reply to Denis Palmeiro [:denispal] from comment #3)

Can we just make the viewport a bit smaller to exclude the statuspanel?

Can you help me understand why that'd be better/easier than using CSS to hide the panel? Could make it transparent / visibility: hidden if we wanted to ensure the cost of creating + writing to it still impacts some of the tests...

Whiteboard: [fxp] → [fxp][webpagetest]

(In reply to :Gijs (he/him) from comment #4)

(In reply to Denis Palmeiro [:denispal] from comment #3)

Can we just make the viewport a bit smaller to exclude the statuspanel?

Can you help me understand why that'd be better/easier than using CSS to hide the panel? Could make it transparent / visibility: hidden if we wanted to ensure the cost of creating + writing to it still impacts some of the tests...

No, you're right that's probably the easier approach. I didn't look close enough at the comments to see that suggestion.

Hi there :)
I searched and tried something to solve it.
The status panel is part of the browser's own UI and Browser doesn't provide the official way to hide it.
We can't handle the statuspanel by JS from what I searched. (Also if we zoom in on the viewport, the screen will only grow bigger, and the satus panel will be visible.)
There is a way to hide the statuspanel that is on the bottom left. But the way should be by hand, not code. [0] (We can't handle the setting too by the JS code.)
If you have any opinions or there is any way I can try more, Feel free to tell me :)

[0]

  1. Enable userChrome.css Customizations
  • Type about:config in Firefox's address bar.
  • Search for toolkit.legacyUserProfileCustomizations.stylesheets and set it to true.
  1. Create the userChrome.css File
  • Find your Firefox profile folder (you can find the path by going to about:support in the web browser).
  • Inside your profile folder, create a folder named chrome if it doesn’t already exist.
  • Inside the chrome folder, create a file named userChrome.css.
  1. Write the code in the userChrome.css
#statuspanel {
  display: none !important;
}
  1. Restart the browser
Flags: needinfo?(gijskruitbosch+bugs)

I don't understand what information you need from me.

This bug is to make a change to the automated test code in Firefox, not for what people personally adjust using userChrome.css. For this we'd want an attribute and a CSS change that hides the progress indicator when that attribute is present, and for the automated test code to set that attribute.

Flags: needinfo?(gijskruitbosch+bugs)

Thanks for comment :) I was wondering if there were any more opinions about the statuspanel, so I made the cc on you.

I think we cannot modify the statuspanel CSS directly by the code except to change it in the way above. It is strict to hide status panel because of security and transparency.
If there is any other opinions, please let me know.

(In reply to :Gijs (he/him) from comment #7)

For this we'd want an attribute and a CSS change that hides the progress indicator when that attribute is present, and for the automated test code to set that attribute.

:gijs, could you elaborate on this proposed solution? Alternatively, do you have any examples that we could work from to do this?

Flags: needinfo?(gijskruitbosch+bugs)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED

I don't know enough about raptor vs WPT visual pageload (comment #2) to know where to set the pref, but either way I've put up a patch that I believe addresses the request wrt raptor. I'm assuming people more familiar with WPT can work out a patch to set the pref there.

Flags: needinfo?(gijskruitbosch+bugs)
Summary: Remove the tooltip/statuspanel from our tests so they are not captured by visual metrics → Remove the statuspanel from our tests so they are not captured by visual metrics

Thank you very much for putting up a patch for this :gijs! The user.js file you added it to is perfect for us on the raptor side.

Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e0dd05f7816f
remove status panel in raptor tests, r=sparky,dao,perftest-reviewers,desktop-theme-reviewers
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 124 Branch
Regressions: 1878843
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: