Last Comment Bug 176310 - setting "font-style" for <Q> affects outside quotation characters as well as actual quote
: setting "font-style" for <Q> affects outside quotation characters as well as ...
Status: RESOLVED INVALID
:
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: Trunk
: x86 Linux
: -- trivial (vote)
: ---
Assigned To: David Baron :dbaron: ⌚️UTC-7
: Hixie (not reading bugmail)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-23 14:07 PDT by Stephen Waters
Modified: 2002-10-23 15:40 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Stephen Waters 2002-10-23 14:07:04 PDT
The code to reproduce:
Q { font-style: italic }

The outside quotation characters end up being italicized instead of just the
quoted statement itself. I think the quotation characters should inherit the
font-style of the surrounding block and only the quote itself should be italicized.

Tested Platforms: 
snapshot Build ID: 2002101608
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020913 Debian/1.1-1
Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913 Debian/1.2.6-2
Comment 1 Hixie (not reading bugmail) 2002-10-23 15:40:09 PDT
INVALID since the quote characters are part of the element's generated content
which per CSS inherits the font of the generating element.

Note You need to log in before you can comment on or make changes to this bug.