Closed Bug 1763207 Opened 2 years ago Closed 2 years ago

Enable peer connection through the socket process by default

Categories

(Core :: WebRTC, enhancement, P2)

Desktop
All
enhancement

Tracking

()

RESOLVED FIXED
101 Branch
Tracking Status
firefox100 --- fixed
firefox101 --- fixed

People

(Reporter: jimm, Assigned: bwc)

Details

Attachments

(1 file)

We've been running an experiment that has gradually increased the rollout to 100%. The final step in the experiment happened in Firefox 99.

The prefs that control this are still targeting early beta, so we need to flip these by default and uplift to 100.

https://experimenter.services.mozilla.com/experiments/moving-some-webrtc-functionality-into-its-own-process/

media.peerconnection.mtransport_process
network.process.enabled

https://searchfox.org/mozilla-central/source/browser/app/profile/firefox.js#2000
https://searchfox.org/mozilla-central/source/modules/libpref/init/StaticPrefList.yaml#10224

Severity: -- → S3
Priority: -- → P2
No longer blocks: webrtc-triage
Assignee: nobody → docfaraday

I guess we want to continue testing no-socket-process on try, since we still have a fallback mode when the socket process crashes.

Pushed by bcampen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f00b62664414
Enable webrtc socket process by default on release. r=mjf
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 101 Branch

Comment on attachment 9270964 [details]
Bug 1763207: Enable webrtc socket process by default on release. r?mjf

Beta/Release Uplift Approval Request

  • User impact if declined:
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): We've been running with this enabled for a long time now, and it seems to work just fine.
  • String changes made/needed: None.
Attachment #9270964 - Flags: approval-mozilla-beta?

Comment on attachment 9270964 [details]
Bug 1763207: Enable webrtc socket process by default on release. r?mjf

Approved for 100.0b4

Attachment #9270964 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.