Closed Bug 1766167 Opened 2 months ago Closed 2 months ago

sitepermissions row should be hidden for non "sitepermission" addon types

Categories

(Toolkit :: Add-ons Manager, defect, P2)

defect
Points:
1

Tracking

()

RESOLVED FIXED
101 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox99 --- wontfix
firefox100 --- wontfix
firefox101 --- fixed

People

(Reporter: rpl, Assigned: rpl)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [addons-jira])

Attachments

(2 files)

In Bug 1741545 we introduced a new row to the addon details card which is used by the addon type "sitepermission" but it should have been actually:

  • hidden when the addon card is associated to any other addon type
  • and the custom element setAddon method shouldn't be called for any other addon type.

From a user perspective the addon card is still working as expected, besides a small regression from a visual perspective due to an additional empty row (see the attached screenshot).

Besides that, a fluent warning is rendered in the webconsole, triggered when the custom element setAddon method is being called, due to the fact that for any other addon type but the "sitepermission" ones the argument that the fluent string is expecting is undefined:

[fluent][resolver] errors in en-US/addon-sitepermissions-required: Resolver error: Unknown variable: $hostname

As a side note:

  • in some of the AOM mochitest-browser tests the fluent warning seems to also have the side-effect of preventing some of the other localized strings used in about:addons from rendering as expected, which doesn't seem to be happening when the same warning is emitted when manually opening about:addons as a user.
  • fixing the fluent warning (by only calling the custom element setAddon method for add-ons with type "sitepermission") seems to fix the missing localized strings in those mochitest-browser tests

Set release status flags based on info from the regressing bug 1741545

Has Regression Range: --- → yes
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/051f7de214a8
AddonSitePermissionsList list should only be visible for sitepermission addon type. r=zombie
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 101 Branch
You need to log in before you can comment on or make changes to this bug.