Support for addressbook lists in filter rules

RESOLVED DUPLICATE of bug 180013

Status

MailNews Core
Filters
--
enhancement
RESOLVED DUPLICATE of bug 180013
15 years ago
10 years ago

People

(Reporter: Xavi Miró, Assigned: Navin Gupta)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
It would be very useful to be able to include addressbook lists in the filter
rules. This enhancement would avoid having to create long filter rules where
each member of a list has to be included individually in a "contains" rule.

For example, one would be able to select a rule like this:

"the <To or CC> <contains someone from the list> friends_list".

 The list would be evaluated at filter time, not at design time (i.e. the _name_
of the list would be stored in the rule and the rule would be evaluated in the
moment the filter is applied). This way, if a list changes its members, the
filter will continue to work as expected without changes.
*** Bug 176654 has been marked as a duplicate of this bug. ***

Comment 2

15 years ago
See also bug 134603 for filtering on addressbook - it's not 100% identical, but
close enough for me to dupe this against. Or we can implement both : filter on
address book *and* filter on address list.

*** This bug has been marked as a duplicate of 134603 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
Argh .. didn't mean to dupe already
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

15 years ago
I think that bug 134603 is oriented to avoid spam, while this bug simply tries
to make filter design easier when you want to store in different folders the
e-mails sent to a group of people. On the other hand, using address lists in
filters would probably solve both problems (or at least the "address list in
filters" feature could be reused to solve the spam problem), because a special
address list could be created (maybe hidden) to include the spam addresses.

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

15 years ago
this is an exact duplicate of bug 162789 upon which bug 13460 depends.

*** This bug has been marked as a duplicate of 162789 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

15 years ago
I'm sorry but I don't agree with you when you think this is a duplicate of bug
162789. That bug works at the _addressbook_ level, while this one works at the
_addresslist_ level. What is more, the functionality that bug offers does not
solve the problem I try to solve with this one.

I want to be able to design a filter that stores in a certain folder any e-mail
sent to a list that I have already defined. If I have to define a new
addressbook for each of my lists (already defined) to be able to design this
filter, this is not the solution I need.
(Reporter)

Comment 7

15 years ago
I reopen the bug, because I think it's not a duplicate of 162789.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 8

15 years ago
Marking as dupe of bug 180013 (which should properly be a dupe of this one, but
as it was reported by a developer and links to another bug with design ideas I
think this is the more useful way to go about it).

*** This bug has been marked as a duplicate of 180013 ***
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.