Closed Bug 1769153 Opened 9 months ago Closed 5 months ago

[clang trunk] error: failed to run custom build command for `gecko-profiler v0.1.0 (/.../tools/profiler/rust-api)`

Categories

(Firefox Build System :: General, defect)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: glandium, Assigned: glandium)

References

(Blocks 1 open bug)

Details

error: failed to run custom build command for `gecko-profiler v0.1.0 (/private/var/opt/generic-worker/tasks/task_165234331867157/checkouts/gecko/tools/profiler/rust-api)`
Caused by:
  process didn't exit successfully: `/private/var/opt/generic-worker/tasks/task_165234331867157/build/obj-build/release/build/gecko-profiler-54b7803c395307aa/build-script-build` (signal: 11, SIGSEGV: invalid memory reference)

This started with https://github.com/llvm/llvm-project/commit/29c8c070a1770fc510ccad3be753f6f50336f8cc
There is something going on with libc++.

This has somehow been fixed by the upgrade to rustc 1.61.

Status: NEW → RESOLVED
Closed: 8 months ago
Depends on: 1771826
Resolution: --- → FIXED

... and it's back with rustc 1.62.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Blocks: clang-15

Worked around with bug 1788870.

Status: REOPENED → RESOLVED
Closed: 8 months ago5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.