Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 176938 - [ps] Printing does not work with some Postscript printers
: [ps] Printing does not work with some Postscript printers
Product: Core
Classification: Components
Component: Printing: Output (show other bugs)
: Trunk
: Other Linux
: P2 major (vote)
: Future
Assigned To: rods (gone)
: sujay
: Jet Villegas (:jet)
Depends on:
  Show dependency treegraph
Reported: 2002-10-26 17:22 PDT by Art Vedas
Modified: 2005-09-23 09:30 PDT (History)
5 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description Art Vedas 2002-10-26 17:22:52 PDT
User-Agent:       Mozilla/4.76 [en] (X11; U; SunOS 5.7 sun4u)
Build Identifier: Mozilla 1.0 and Netscape 7

Postscript printing fails on some printers with various errors; some of them
indicare postscript errors as the source of the problem, others report errors
with blinking red LEDs... ;-(

Filing a service call to HP stopped at the following point:
HP customer support said that the generated Postscript code only works with
Postscript Level 3 printers, the printer we are using only supports Level 2.

The problem occurs on both Unix (Solaris 8) and Linux with Mozilla 1.0 and
Netscape 7

Reproducible: Always

Steps to Reproduce:
1. Go to
2. Set number of hits to "100"
3. Search for "mozilla"
4. Print the page

Actual Results:  
Two pages print, then the printer stops with an Postscript error

Expected Results:  
The print job should finish completely.
Comment 1 rods (gone) 2002-10-28 07:05:50 PST
Anybody elese seeing this?
Comment 2 Roland Mainz 2002-10-30 03:22:56 PST
rods wrote:
> Anybody elese seeing this?

We had such reports multiple times in the past, but they usually get closed
after a month due their "unconfirmed" status... ;-(

The workarounds are:
- Use Ghostscript to convert Mozilla's output to PS Level 2
- Use Xprint
Comment 3 Kenneth Herron 2004-02-15 13:53:03 PST
Supporting level 2 postscript is bug 107756.

We have various bugs about problems with HP printers. So far I haven't seen
anyone identify what specifically HP's postscript engine doesn't like about
mozilla's output. If we knew what it was, we might be able to work around it.
Comment 4 Roland Mainz 2004-02-15 14:30:00 PST
This was NEVER a problem restricted to HP printers. Lexmark and Textronic(sp?)
were always affected, too.
Comment 5 Kenneth Herron 2005-04-26 11:14:11 PDT
Art or anyone else, are you experiencing this problem with current versions of
mozilla? There have been several changes to the postscript code generator since
this bug was filed, and it's possible that whatever was causing this problem has

Assuming someone can reproduce this, please attach a sample print job that
triggers the problem.
Comment 6 Kenneth Herron 2005-09-23 08:53:28 PDT
I'm going to close this because there's no evidence the issue still exists with
current versions of mozilla. If anyone can reproduce this with something
current, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.