[ps] Printing does not work with some Postscript printers

RESOLVED WORKSFORME

Status

()

Core
Printing: Output
P2
major
RESOLVED WORKSFORME
15 years ago
12 years ago

People

(Reporter: Art Vedas, Assigned: rods (gone))

Tracking

Trunk
Future
Other
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.76 [en] (X11; U; SunOS 5.7 sun4u)
Build Identifier: Mozilla 1.0 and Netscape 7

Postscript printing fails on some printers with various errors; some of them
indicare postscript errors as the source of the problem, others report errors
with blinking red LEDs... ;-(

Filing a service call to HP stopped at the following point:
HP customer support said that the generated Postscript code only works with
Postscript Level 3 printers, the printer we are using only supports Level 2.

The problem occurs on both Unix (Solaris 8) and Linux with Mozilla 1.0 and
Netscape 7

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.google.com/
2. Set number of hits to "100"
3. Search for "mozilla"
4. Print the page

Actual Results:  
Two pages print, then the printer stops with an Postscript error

Expected Results:  
The print job should finish completely.
Severity: blocker → major
(Assignee)

Comment 1

15 years ago
Anybody elese seeing this?

Comment 2

15 years ago
rods wrote:
> Anybody elese seeing this?

We had such reports multiple times in the past, but they usually get closed
after a month due their "unconfirmed" status... ;-(

The workarounds are:
- Use Ghostscript to convert Mozilla's output to PS Level 2
- Use Xprint
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Printing does not work with some Postscript printers → [ps] Printing does not work with some Postscript printers

Updated

15 years ago
Priority: -- → P2
Target Milestone: --- → Future

Comment 3

13 years ago
Supporting level 2 postscript is bug 107756.

We have various bugs about problems with HP printers. So far I haven't seen
anyone identify what specifically HP's postscript engine doesn't like about
mozilla's output. If we knew what it was, we might be able to work around it.
Summary: [ps] Printing does not work with some Postscript printers → [ps] Printing does not work with some HP Postscript printers

Comment 4

13 years ago
This was NEVER a problem restricted to HP printers. Lexmark and Textronic(sp?)
were always affected, too.
Summary: [ps] Printing does not work with some HP Postscript printers → [ps] Printing does not work with some Postscript printers

Comment 5

12 years ago
Art or anyone else, are you experiencing this problem with current versions of
mozilla? There have been several changes to the postscript code generator since
this bug was filed, and it's possible that whatever was causing this problem has
changed.

Assuming someone can reproduce this, please attach a sample print job that
triggers the problem.

Comment 6

12 years ago
I'm going to close this because there's no evidence the issue still exists with
current versions of mozilla. If anyone can reproduce this with something
current, please open a new bug report.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.