Closed Bug 1769890 Opened 2 years ago Closed 2 years ago

[Wayland] Bookmark edit menu freeze when editing tags

Categories

(Core :: Graphics, defect, P3)

Firefox 100
Unspecified
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1771104

People

(Reporter: astrothayne, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:100.0) Gecko/20100101 Firefox/100.0

Steps to reproduce:

  1. Bookmark a page by clicking on the star in the url bar
  2. Focus on "Tags" in the "Add bookmark" dialog
  3. Begin typing

Actual results:

The "Add bookmark" dialog freezes up for a couple of seconds, and isn't responsive. After waiting for a few seconds it becomes responsive again, but how long it takes to become responsive again depends on what I typed.

Expected results:

The tags input for adding bookmarks should be responsive.

Also, this happens when running firefox in wayland with MOZ_ENABLE_WAYLAND=1. When I run without MOZ_ENABLE_WAYLAND=1, then I don't encounter this issue.

OS: Unspecified → Linux
Summary: Bookmark edit menu freeze when editing tags → [Wayland] Bookmark edit menu freeze when editing tags
Component: Untriaged → Bookmarks & History
Blocks: wayland

Moving to core/graphics since this is wayland specific.

Component: Bookmarks & History → Graphics
Product: Firefox → Core

Andrew, can you reproduce this?

Severity: -- → S3
Flags: needinfo?(aosmond)
Priority: -- → P3

Should be a dupe of Bug 1771104. Please test latest nightly and reopen if you can reproduce it:
https://fedoraproject.org/wiki/How_to_debug_Firefox_problems#Testing_Mozilla_binaries
Thanks.

Blocks: wayland-popup
No longer blocks: wayland
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE

Seems to be fixed on nightly for me.

You need to log in before you can comment on or make changes to this bug.