microsoft.com pages don't display correctly

VERIFIED DUPLICATE of bug 159494

Status

--
major
VERIFIED DUPLICATE of bug 159494
16 years ago
4 years ago

People

(Reporter: tim+mozilla.org, Assigned: susiew)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
I'm concerned that this could be something to do with my machine set up as I
can't find it in bugzilla.
when I load the above url, the main content pane has the text wrongly overlaid.
(I can't attach a file, but, for example, the lines starting with 1,2,3 all
appear in one place.

version of mozilla is 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826
xp is un-service packed (I don't like their change in contract terms),
machine is ibm thinkpad t23.

I've put this in as major, but if you do anything with ms support sites, it's
worse than that :-)

tc
I spent quite a while figuring out what was going on.  IT turns out the problem
is in the stylesheet
http://support.microsoft.com/common/css/GN/en-us/down-other/KBArticle.css ,
which has a number of declarations of the form "margin-bottom: -1%" or
"margin-bottom: -1em".  This are explicit requests for overlap.  Note that
percentages are relative to the width of the containing block.  I'm guessing
that WinIE either doesn't support negative margins correctly or does percentage
vertical margins relative to some height.  (In any case, I'd expect to see the
overlap in MacIE as well.  If true, this might be a good way to point out the
problem to Microsoft.)

In any case, ->evangelism.
Assignee: font → susiew
Component: Layout: Fonts and Text → US General
Product: Browser → Tech Evangelism
QA Contact: ylong → zach
Version: other → unspecified

Comment 3

16 years ago
I think this is a DUP of bug 159494

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 159494 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
Verified.
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.