[Blocker][PP][IME] Crash on KO text input

VERIFIED FIXED in M12

Status

()

P3
blocker
VERIFIED FIXED
19 years ago
9 years ago

People

(Reporter: blee, Assigned: ftang)

Tracking

({inputmethod})

Trunk
x86
Windows NT
inputmethod
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
To reproduce,
Switch on KO IME upon opening Composer and start typing in KO text.
==> crash as soon as a KO character is typed in.

Stack Trace info not available (TalkBack didn't engage)

warning message reads:       mozilla.exe
Exception: Access Violation (0xc0000005), address: 0x77f05a46

bld: Win 11-01-09-M11
(Reporter)

Updated

19 years ago
QA Contact: teruko → blee

Updated

19 years ago
Blocks: 16127
(Assignee)

Updated

19 years ago
Blocks: 12253
Status: NEW → ASSIGNED
(Assignee)

Comment 1

19 years ago
this is blocking the test of 12253.
(Assignee)

Updated

19 years ago
Target Milestone: M11
(Assignee)

Updated

19 years ago
Severity: normal → blocker
Summary: [PP][IME] Crash on KO text input → [Blocker][PP][IME] Crash on KO text input
Whiteboard: blee is currently install WinNT Ko into my machine so I can debug.
(Assignee)

Updated

19 years ago
Target Milestone: M11 → M12
(Assignee)

Comment 2

19 years ago
Need Korean NT/95/98 dev machine to debug this. Move to M12
(Assignee)

Comment 3

19 years ago
I got Korean NT installed. But I cannot reproduce this problem.
(Reporter)

Updated

19 years ago
(Reporter)

Comment 4

19 years ago
I don't know why it still (11-09-11-M11 bld) happens on my machine.
Got stack trace (URL aobve) this time.
(Assignee)

Comment 5

19 years ago
I think the crash is in the line 3909
we should ensure mIMECursorPosition < mIMECompositionString before come to
here...
3909     substringLength =
::MultiByteToWideChar(mCurrentKeyboardCP,MB_PRECOMPOSED,mIMECompositionString,
3910                 mIMECursorPosition,NULL,0);

Updated

19 years ago
Blocks: 18471
(Assignee)

Updated

19 years ago
Whiteboard: blee is currently install WinNT Ko into my machine so I can debug.
(Assignee)

Comment 6

19 years ago
fix and check in. Thansk for blee's great stact trace.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

19 years ago
Fixed in Win32 11-11-09-M12 bld.

Updated

19 years ago
No longer blocks: 18471
Keywords: inputmethod
You need to log in before you can comment on or make changes to this bug.