Closed Bug 1771836 Opened 6 months ago Closed 5 months ago

Intermittent gfx/layers/apz/test/mochitest/test_group_keyboard.html | Test timed out. -

Categories

(Core :: Panning and Zooming, defect, P5)

defect

Tracking

()

RESOLVED FIXED
104 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox101 --- unaffected
firefox102 --- unaffected
firefox103 --- fixed
firefox104 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: botond)

References

(Regression)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell needswork:owner])

Attachments

(1 file)

Filed by: ccozmuta [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer?job_id=379694656&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/DvLhzjFTQDeGPLiMtbKGXg/runs/0/artifacts/public/logs/live_backing.log
Reftest URL: https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/DvLhzjFTQDeGPLiMtbKGXg/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1


[task 2022-05-31T01:43:33.758Z] 01:43:33     INFO - TEST-PASS | gfx/layers/apz/test/mochitest/test_group_keyboard.html | The page did not scroll [origin: page, smooth: true] 
[task 2022-05-31T01:43:33.758Z] 01:43:33     INFO - TEST-PASS | gfx/layers/apz/test/mochitest/test_group_keyboard.html | Scrolled only once, but expecting a smooth transtion [origin: page; msdPhysics: true] 
[task 2022-05-31T01:43:33.759Z] 01:43:33     INFO - TEST-PASS | gfx/layers/apz/test/mochitest/test_group_keyboard.html | Expected to be scrolled to origin, actually scrolled to 0 
[task 2022-05-31T01:43:33.759Z] 01:43:33     INFO - Testing Scrolling preferences. [origin: page; smooth: false; msdPhysics: false; 736.8000000000001]
[task 2022-05-31T01:43:33.760Z] 01:43:33     INFO - Scrolled to 887
[task 2022-05-31T01:43:33.760Z] 01:43:33     INFO - TEST-PASS | gfx/layers/apz/test/mochitest/test_group_keyboard.html | The page did not scroll [origin: page, smooth: false] 
[task 2022-05-31T01:43:33.761Z] 01:43:33     INFO - TEST-PASS | gfx/layers/apz/test/mochitest/test_group_keyboard.html | Scrolled more than once, but expecting an instant scroll [origin: page; msdPhysics: false] 
[task 2022-05-31T01:43:33.761Z] 01:43:33     INFO - Buffered messages logged at 01:38:45
[task 2022-05-31T01:43:33.761Z] 01:43:33     INFO - TEST-PASS | gfx/layers/apz/test/mochitest/test_group_keyboard.html | Expected to be scrolled to origin, actually scrolled to 0 
[task 2022-05-31T01:43:33.762Z] 01:43:33     INFO - Testing Scrolling preferences. [origin: page; smooth: false; msdPhysics: false; 736.8000000000001]
[task 2022-05-31T01:43:33.762Z] 01:43:33     INFO - Scrolled to 887
[task 2022-05-31T01:43:33.763Z] 01:43:33     INFO - TEST-PASS | gfx/layers/apz/test/mochitest/test_group_keyboard.html | The page did not scroll [origin: page, smooth: false] 
[task 2022-05-31T01:43:33.763Z] 01:43:33     INFO - TEST-PASS | gfx/layers/apz/test/mochitest/test_group_keyboard.html | Scrolled more than once, but expecting an instant scroll [origin: page; msdPhysics: false] 
[task 2022-05-31T01:43:33.763Z] 01:43:33     INFO - Buffered messages finished
[task 2022-05-31T01:43:33.764Z] 01:43:33     INFO - TEST-UNEXPECTED-FAIL | gfx/layers/apz/test/mochitest/test_group_keyboard.html | Test timed out. - 
[task 2022-05-31T01:43:34.594Z] 01:43:34     INFO - GECKO(2084) | MEMORY STAT | vsize 527MB | vsizeMaxContiguous 1293MB | residentFast 61MB | heapAllocated 5MB
[task 2022-05-31T01:43:35.613Z] 01:43:35     INFO - TEST-OK | gfx/layers/apz/test/mochitest/test_group_keyboard.html | took 302175ms
[task 2022-05-31T01:43:36.617Z] 01:43:36     INFO - Not taking screenshot here: see the one that was previously logged
[task 2022-05-31T01:43:36.620Z] 01:43:36     INFO - TEST-UNEXPECTED-FAIL | gfx/layers/apz/test/mochitest/test_group_keyboard.html | Test timed out. - 
[task 2022-05-31T01:43:37.621Z] 01:43:37    ERROR - TEST-UNEXPECTED-FAIL | SimpleTest | this test already called finish!
[task 2022-05-31T01:43:37.627Z] 01:43:37     INFO - TEST-UNEXPECTED-ERROR | gfx/layers/apz/test/mochitest/test_group_keyboard.html | called finish() multiple times
[task 2022-05-31T01:43:37.627Z] 01:43:37     INFO - TEST-INFO 
[task 2022-05-31T01:43:39.628Z] 01:43:39     INFO - Not taking screenshot here: see the one that was previously logged
[task 2022-05-31T01:43:39.631Z] 01:43:39     INFO - TEST-UNEXPECTED-FAIL | gfx/layers/apz/test/mochitest/test_group_keyboard.html | Test timed out. - 
[task 2022-05-31T01:43:39.632Z] 01:43:39     INFO - Error: Unable to restore focus, expect failures and timeouts.
[task 2022-05-31T01:43:39.642Z] 01:43:39     INFO - TEST-START | Shutdown
[task 2022-05-31T01:43:39.642Z] 01:43:39     INFO - Passed:  925
[task 2022-05-31T01:43:39.643Z] 01:43:39     INFO - Failed:  1
[task 2022-05-31T01:43:39.643Z] 01:43:39     INFO - Todo:    0
[task 2022-05-31T01:43:39.644Z] 01:43:39     INFO - Mode:    e10s
[task 2022-05-31T01:43:39.644Z] 01:43:39     INFO - Slowest: 302175ms - /tests/gfx/layers/apz/test/mochitest/test_group_keyboard.html
[task 2022-05-31T01:43:39.645Z] 01:43:39     INFO - TEST-INFO | Ran 8 Loops
[task 2022-05-31T01:43:39.645Z] 01:43:39     INFO - SimpleTest FINISHED
[task 2022-05-31T01:43:39.652Z] 01:43:39     INFO - GECKO(2084) | Exiting due to channel error.
[task 2022-05-31T01:43:39.652Z] 01:43:39     INFO - GECKO(2084) | Exiting due to channel error.
[task 2022-05-31T01:43:39.729Z] 01:43:39     INFO - TEST-INFO | Main app process: exit 0

:hiro, since you are the author of the regressor, bug 1312165, could you take a look?
For more information, please visit auto_nag documentation.

Flags: needinfo?(hikezoe.birchill)

I believe the root cause of these new failures is same as bug 1768701. I will handle it in bug 1768701.

Flags: needinfo?(hikezoe.birchill)
See Also: → 1768701
Has Regression Range: --- → yes

Set release status flags based on info from the regressing bug 1312165

Summary: Intermittent TV gfx/layers/apz/test/mochitest/test_group_keyboard.html | Test timed out. - → Intermittent tier 2 gfx/layers/apz/test/mochitest/test_group_keyboard.html | Test timed out. -
Summary: Intermittent tier 2 gfx/layers/apz/test/mochitest/test_group_keyboard.html | Test timed out. - → Intermittent gfx/layers/apz/test/mochitest/test_group_keyboard.html | Test timed out. -

There are 83 total failures in the last 7 days on

  • macosx1015-64-qr opt and debug
  • macosx1015-64-shippable-qr opt

Recent failure log: https://treeherder.mozilla.org/logviewer?job_id=382574518&repo=autoland&lineNumber=52917

[task 2022-06-27T00:40:43.179Z] 00:40:43     INFO - TEST-PASS | gfx/layers/apz/test/mochitest/test_group_keyboard.html | The page did not scroll [origin: page, smooth: true] 
[task 2022-06-27T00:40:43.179Z] 00:40:43     INFO - TEST-PASS | gfx/layers/apz/test/mochitest/test_group_keyboard.html | Scrolled only once, but expecting a smooth transtion [origin: page; msdPhysics: false] 
[task 2022-06-27T00:40:43.180Z] 00:40:43     INFO - TEST-PASS | gfx/layers/apz/test/mochitest/test_group_keyboard.html | Expected to be scrolled to origin, actually scrolled to 0 
[task 2022-06-27T00:40:43.180Z] 00:40:43     INFO - Testing Scrolling preferences. [origin: line; smooth: false; msdPhysics: true; 50]
[task 2022-06-27T00:40:43.181Z] 00:40:43     INFO - Scrolled to 80
[task 2022-06-27T00:40:43.181Z] 00:40:43     INFO - TEST-PASS | gfx/layers/apz/test/mochitest/test_group_keyboard.html | The page did not scroll [origin: line, smooth: false] 
[task 2022-06-27T00:40:43.181Z] 00:40:43     INFO - TEST-PASS | gfx/layers/apz/test/mochitest/test_group_keyboard.html | Scrolled more than once, but expecting an instant scroll [origin: line; msdPhysics: true] 
[task 2022-06-27T00:40:43.182Z] 00:40:43     INFO - TEST-PASS | gfx/layers/apz/test/mochitest/test_group_keyboard.html | Expected to be scrolled to origin, actually scrolled to 0 
[task 2022-06-27T00:40:43.182Z] 00:40:43     INFO - Testing Scrolling preferences. [origin: line; smooth: false; msdPhysics: true; 50]
[task 2022-06-27T00:40:43.183Z] 00:40:43     INFO - Scrolled to 80
[task 2022-06-27T00:40:43.183Z] 00:40:43     INFO - TEST-PASS | gfx/layers/apz/test/mochitest/test_group_keyboard.html | The page did not scroll [origin: line, smooth: false] 
[task 2022-06-27T00:40:43.183Z] 00:40:43     INFO - TEST-PASS | gfx/layers/apz/test/mochitest/test_group_keyboard.html | Scrolled more than once, but expecting an instant scroll [origin: line; msdPhysics: true] 
[task 2022-06-27T00:40:43.183Z] 00:40:43     INFO - TEST-PASS | gfx/layers/apz/test/mochitest/test_group_keyboard.html | Expected to be scrolled to origin, actually scrolled to 0 
[task 2022-06-27T00:40:43.184Z] 00:40:43     INFO - Testing Scrolling preferences. [origin: line; smooth: true; msdPhysics: true; 50]
[task 2022-06-27T00:40:43.184Z] 00:40:43     INFO - Scrolled to 79
[task 2022-06-27T00:40:43.185Z] 00:40:43     INFO - TEST-PASS | gfx/layers/apz/test/mochitest/test_group_keyboard.html | The page did not scroll [origin: line, smooth: true] 
[task 2022-06-27T00:40:43.185Z] 00:40:43     INFO - TEST-PASS | gfx/layers/apz/test/mochitest/test_group_keyboard.html | Scrolled only once, but expecting a smooth transtion [origin: line; msdPhysics: true] 
[task 2022-06-27T00:40:43.185Z] 00:40:43     INFO - TEST-PASS | gfx/layers/apz/test/mochitest/test_group_keyboard.html | Expected to be scrolled to origin, actually scrolled to 0 
[task 2022-06-27T00:40:43.186Z] 00:40:43     INFO - Testing Scrolling preferences. [origin: line; smooth: false; msdPhysics: false; 50]
[task 2022-06-27T00:40:43.186Z] 00:40:43     INFO - Scrolled to 80
[task 2022-06-27T00:40:43.187Z] 00:40:43     INFO - TEST-PASS | gfx/layers/apz/test/mochitest/test_group_keyboard.html | The page did not scroll [origin: line, smooth: false] 
[task 2022-06-27T00:40:43.187Z] 00:40:43     INFO - TEST-PASS | gfx/layers/apz/test/mochitest/test_group_keyboard.html | Scrolled more than once, but expecting an instant scroll [origin: line; msdPhysics: false] 
[task 2022-06-27T00:40:43.187Z] 00:40:43     INFO - Buffered messages finished
[task 2022-06-27T00:40:43.187Z] 00:40:43     INFO - TEST-UNEXPECTED-FAIL | gfx/layers/apz/test/mochitest/test_group_keyboard.html | Test timed out. - 
[task 2022-06-27T00:40:44.170Z] 00:40:44     INFO - GECKO(3713) | MEMORY STAT | vsize 6665MB | residentFast 119MB | heapAllocated 8MB
[task 2022-06-27T00:40:45.324Z] 00:40:45     INFO - TEST-OK | gfx/layers/apz/test/mochitest/test_group_keyboard.html | took 325364ms
[task 2022-06-27T00:40:48.459Z] 00:40:48     INFO - Error: Unable to restore focus, expect failures and timeouts.
[task 2022-06-27T00:40:48.467Z] 00:40:48     INFO - GECKO(3713) | [Parent 3713, Main Thread] WARNING: Received `load` event on unbridged BrowserParent!: file /builds/worker/checkouts/gecko/dom/ipc/BrowserParent.cpp:4012
[task 2022-06-27T00:40:48.468Z] 00:40:48     INFO - GECKO(3713) | [Parent 3713, Main Thread] WARNING: Received `load` event on unbridged BrowserParent!: file /builds/worker/checkouts/gecko/dom/ipc/BrowserParent.cpp:4012

Botond, can you please take a look?

Flags: needinfo?(botond)
Whiteboard: [stockwell needswork:owner]

When did this failure get more frequent than before?

Flags: needinfo?(apavel)

(In reply to Hiroyuki Ikezoe (:hiro) from comment #10)

When did this failure get more frequent than before?

Hi. Based on intermittent failures view, this started on the 19th, with a spike during 25th-26th of June: https://treeherder.mozilla.org/intermittent-failures/bugdetails?startday=2022-05-30&endday=2022-06-29&tree=trunk&bug=1771836

Failures are on macosx1015-64-qr and macosx1015-64-shippable-qr opt and debug.

Flags: needinfo?(apavel)

It's not obvious from the logs (due to a test issue I'm fixing in bug 1777151), but the failing subtest is helper_bug1756529.html.

This subtest has been suffering from various flakiness problems (e.g. it's skipped on Linux) and it doesn't seem to me like a particularly high-value test (it's testing a fairly small code change that only affects non-default pref configurations). I'm going to move it into its own test group, and then we can probably disable it on platforms where it's very flaky.

Flags: needinfo?(botond)
Assignee: nobody → botond
Status: NEW → ASSIGNED
Pushed by bballo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0ae17e1144c9
Split helper_bug1756529 out into its own test group. r=hiro

Hi,
Since this landed , we have some failures like https://treeherder.mozilla.org/logviewer?job_id=382949739&repo=autoland&lineNumber=38570

Can you please take a look ?
Thank you!

Flags: needinfo?(botond)
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 104 Branch
Regressions: 1777482

(In reply to Cristina Cozmuta (:CrissCozmuta) from comment #17)

Since this landed , we have some failures like https://treeherder.mozilla.org/logviewer?job_id=382949739&repo=autoland&lineNumber=38570

Can you please take a look ?

Addressed in bug 1777482.

Flags: needinfo?(botond)
You need to log in before you can comment on or make changes to this bug.