Closed Bug 1771899 Opened 8 months ago Closed 8 months ago

Spotlight's fancy/gradient title is not visible when selected if the "Dark" theme is enabled

Categories

(Firefox :: Messaging System, defect, P1)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
103 Branch
Iteration:
103.1 - May 30 - June 10
Tracking Status
firefox101 --- wontfix
firefox102 --- wontfix
firefox103 --- verified

People

(Reporter: mcoman, Assigned: mviar)

References

(Blocks 2 open bugs)

Details

Attachments

(2 files)

Attached image ss of the issue (2).png

[Notes]:

  • This issue is most easily reproduced on macOS, however, the issue is also reproducible on Windows 10 x64, but the spotlight must be unfocused after the tile is selected.

[Affected versions]:

  • Firefox Release 101.0 - Build ID: 20220526203855
  • Firefox Beta 102.0b1 - Build ID: 20220530132252
  • Firefox Nightly 103.0a1 - Build ID: 20220530190626

[Affected Platforms]:

  • Windows 10 x64
  • macOS 11.6.2

[Prerequisites]:

  • Have the following prefs in the "about:config" page:
    • "nimbus.debug" pref set to "true".
    • "browser.newtabpage.activity-stream.asrouter.devtoolsEnabled" pref set to "true".
  • Have the browser's "Dark" theme enabled from "about:addons>Themes" page.

[Steps to reproduce]:

  1. Open the browser with the profile from the prerequisites.
  2. Navigate to the "about:studies?optin_slug=next-level-pin-infrequent-eco2205-en&optin_branch=treatment-b&optin_collection=nimbus-preview" URL.
  3. Navigate to the "about:newtab#asrouter" page and search for the "next-level-pin-infrequent-eco2205-en:treatment-b" message.
  4. Click the message related "Show" button and observe the spotlight's title.

[Expected result]:

  • The spotlight's title is selected and visible.

[Actual result]:

  • The spotlight's title is not visible when selected.

[Additional Notes]:

  • This issue is not reproducible if the browser's "Light" theme is enabled.
  • This issue is not reproducible on Linux Mint 20.2 x64.
  • This issue is reproducible across all the "May Multiplier Next Level" experiments.
  • Attached a screenshot of the issue.

Treatment b uses color text in the title which seems to be the origin of issue. Edge case that's not blocker for this experiment .

Priority: -- → P3
Iteration: --- → 103.1 - May 30 - June 10
Priority: P3 → P1
Summary: [Experiment] The spotlight's title from the "treatment b" branch of the "Next Level" experiment is not visible when selected if the "Dark" theme is enabled → Spotlight's fancy/gradient title is not visible when selected if the "Dark" theme is enabled
Assignee: nobody → mviar
Pushed by mviar@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6198d8f27e77
Spotlight's fancy/gradient title is not visible when selected if the Dark theme is enabled r=pdahiya
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 103 Branch

The patch landed in nightly and beta is affected.
:mviar, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(mviar)

I‘ve verified this issue using the latest Firefox Nightly 103.0a1 (Build ID: 20220609220048) on Windows 10 x64, macOS 12.3.1.

  • Spotlight's fancy/gradient title is visible when selected if the Dark theme is enabled. Verified the
    “Fx100 Upgrade” and “next-level-pin-core-eco2205-en:treatment-b” spotlights.
Status: RESOLVED → VERIFIED

I confirmed with product that we won't be uplifting to beta as this is an edge case.

Flags: needinfo?(mviar)
You need to log in before you can comment on or make changes to this bug.