Closed Bug 1771963 Opened 4 months ago Closed 2 months ago

Intermittent TV toolkit/components/reader/test/browser_readerMode_refresh.js | Test timed out -

Categories

(Toolkit :: Reader Mode, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1776032
Tracking Status
firefox-esr91 --- unaffected
firefox101 --- unaffected
firefox102 --- unaffected
firefox103 --- wontfix

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure, regression)

Filed by: nerli [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer?job_id=379765988&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/fdeaGo7JTgCO98-q8o0jdw/runs/0/artifacts/public/logs/live_backing.log
Reftest URL: https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/fdeaGo7JTgCO98-q8o0jdw/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1


[task 2022-05-31T16:21:23.983Z] 16:21:23     INFO - TEST-START | toolkit/components/reader/test/browser_readerMode_refresh.js
[task 2022-05-31T16:21:29.467Z] 16:21:29     INFO - GECKO(1843) | 2022-05-31 16:21:29.466 firefox[1843:30146] Persistent UI failed to open file file:///Users/cltbld/Library/Saved%20Application%20State/org.mozilla.nightly.savedState/window_1.data: No such file or directory (2)
[task 2022-05-31T16:22:09.121Z] 16:22:09     INFO - TEST-INFO | started process screencapture
[task 2022-05-31T16:22:09.249Z] 16:22:09     INFO - TEST-INFO | screencapture: exit 0
[task 2022-05-31T16:22:09.249Z] 16:22:09     INFO - Buffered messages logged at 16:21:23
[task 2022-05-31T16:22:09.249Z] 16:22:09     INFO - Entering test bound 
[task 2022-05-31T16:22:09.250Z] 16:22:09     INFO - Buffered messages logged at 16:21:26
[task 2022-05-31T16:22:09.250Z] 16:22:09     INFO - Console message: [JavaScript Warning: "This page is in Quirks Mode. Page layout may be impacted. For Standards Mode use “<!DOCTYPE html>”." {file: "resource://gre/modules/ReaderMode.jsm" line: 521}]
[task 2022-05-31T16:22:09.251Z] 16:22:09     INFO - Buffered messages logged at 16:21:28
[task 2022-05-31T16:22:09.251Z] 16:22:09     INFO - Console message: While creating services from category 'speech-synth-started', could not create service for entry 'OSX Speech Synth', contract ID '@mozilla.org/synthsystem;1'
[task 2022-05-31T16:22:09.252Z] 16:22:09     INFO - Buffered messages finished
[task 2022-05-31T16:22:09.252Z] 16:22:09     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/reader/test/browser_readerMode_refresh.js | Test timed out - 
[task 2022-05-31T16:22:09.253Z] 16:22:09     INFO - GECKO(1843) | MEMORY STAT vsizeMaxContiguous not supported in this build configuration.
[task 2022-05-31T16:22:09.253Z] 16:22:09     INFO - GECKO(1843) | MEMORY STAT | vsize 8654MB | residentFast 274MB | heapAllocated 110MB
[task 2022-05-31T16:22:09.253Z] 16:22:09     INFO - TEST-OK | toolkit/components/reader/test/browser_readerMode_refresh.js | took 45155ms
[task 2022-05-31T16:22:09.254Z] 16:22:09     INFO - Not taking screenshot here: see the one that was previously logged
[task 2022-05-31T16:22:09.254Z] 16:22:09     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/reader/test/browser_readerMode_refresh.js | Found a tab after previous test timed out: about:reader?url=http%3A%2F%2Fexample.com%2Fbrowser%2Ftoolkit%2Fcomponents%2Freader%2Ftest%2FreaderModeArticle.html - 
[task 2022-05-31T16:22:09.255Z] 16:22:09     INFO - checking window state
[task 2022-05-31T16:22:09.294Z] 16:22:09     INFO - GECKO(1843) | Completed ShutdownLeaks collections in process 1843

:Gijs, since you are the author of the regressor, bug 1760602, could you take a look?
For more information, please visit auto_nag documentation.

Flags: needinfo?(gijskruitbosch+bugs)

https://hg.mozilla.org/integration/autoland/rev/e59ceb417f698e73b1df21186711eb78359ee8f3 made the test actually wait for a refresh to have happened. I don't know why that would cause the test to fail...

Flags: needinfo?(gijskruitbosch+bugs)
Has Regression Range: --- → yes
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1776032
You need to log in before you can comment on or make changes to this bug.