Closed Bug 1772166 Opened 8 months ago Closed 1 month ago

defaultZoomFactor not affected by global/default zoom

Categories

(WebExtensions :: General, defect, P5)

Firefox 101
defect

Tracking

(firefox101 wontfix, firefox102 wontfix, firefox103 wontfix, firefox110 fixed)

RESOLVED FIXED
110 Branch
Tracking Status
firefox101 --- wontfix
firefox102 --- wontfix
firefox103 --- wontfix
firefox110 --- fixed

People

(Reporter: robbendebiene, Assigned: gregp)

Details

(Keywords: dev-doc-complete)

Attachments

(2 files)

Attached image zoomdef.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:100.0) Gecko/20100101 Firefox/100.0

Steps to reproduce:

Set a default zoom value other than 100% in the Firefox settings page and run the following webextension code for a specific tab:

const zoomSettings = await browser.tabs.getZoomSettings(
  tabId
);
console.log(zoomSettings.defaultZoomFactor);

Actual results:

The returned defaultZoomFactor value is always 1 regardless of the value set in the Firefox settings page.

Expected results:

The defaultZoomFactor should reflect the value set in the Firefox settings page.

Hello,

I reproduced the issue on the latest Nightly (103.0a1/20220602093647), Beta (102.0b3/20220602190016) and Release (101.0/20220526203855) under Windows 10 x64 and Ubuntu 16.04 LTS.

Running the code snippet will return the value 1, regardless of the default zoom value set in the Firefox settings page, as described in Comment 0.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → gp3033
Status: NEW → ASSIGNED

There is some behavior differences between chrome and firefox we may want to add to the documentation.

Keywords: dev-doc-needed

Backed out for causing bc failures in browser/components/extensions/test/browser/browser_ext_webNavigation_onCreatedNavigationTarget.js

Backout link: https://hg.mozilla.org/integration/autoland/rev/8074340029a33f955bcb7ac2dba1619d33650c3a

Push with failures

Failure log

INFO - TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/browser_ext_webNavigation_onCreatedNavigationTarget.js | Test timed out - 
[task 2022-12-05T16:06:16.608Z] 16:06:16     INFO - Not taking screenshot here: see the one that was previously logged
[task 2022-12-05T16:06:16.609Z] 16:06:16     INFO - TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/browser_ext_webNavigation_onCreatedNavigationTarget.js | no tasks awaiting on messages - Got "[\"webNavOnCreated\"]", expected "[]"
[task 2022-12-05T16:06:16.609Z] 16:06:16     INFO - Stack trace:
Flags: needinfo?(gp3033)

Thanks, looking.

Flags: needinfo?(gp3033)

I'm having trouble reproducing this failure locally.

Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/470fffc6ff9a
Implement 'ZoomSettings.defaultZoomFactor' r=mixedpuppy,extension-reviewers

Still can't reproduce this locally. I have some theories but testing them would require access to Try...

Flags: needinfo?(gp3033)

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:gregp, could you have a look please?
If you still have some work to do, you can add an action "Plan Changes" in Phabricator.
For more information, please visit auto_nag documentation.

Flags: needinfo?(mixedpuppy)
Flags: needinfo?(gp3033)

Still working on this

Flags: needinfo?(mixedpuppy)
Flags: needinfo?(gp3033)
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/878a8a888ce1
Implement 'ZoomSettings.defaultZoomFactor' r=mixedpuppy,extension-reviewers
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 110 Branch

See

You need to log in before you can comment on or make changes to this bug.