Closed Bug 1772476 Opened 2 years ago Closed 2 years ago

[CTW] CachedTableAccessible not invalidated when a cell is moved

Categories

(Core :: Disability Access APIs, defect)

defect

Tracking

()

RESOLVED FIXED
105 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox-esr102 --- disabled
firefox101 --- disabled
firefox102 --- disabled
firefox103 --- disabled
firefox104 --- disabled
firefox105 --- fixed

People

(Reporter: Jamie, Assigned: Jamie)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [ctw-m3])

Attachments

(1 file)

If you move a cell out of a CachedTableAccessible using aria-owns, the CachedTableAccessible doesn't get invalidated. This is pretty nasty. This applies to both local and remote Accessibles.

Has Regression Range: --- → yes

Set release status flags based on info from the regressing bug 1735970

:jamie is this planned to be enabled in 103 for testing?

Flags: needinfo?(jteh)

No, it won't be enabled in 103.

Flags: needinfo?(jteh)
Whiteboard: [ctw-m3]
Pushed by jteh@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/616436b07b92
Invalidate a CachedTableAccessible when a cell is moved out of it. r=morgan
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 105 Branch

Since nightly and release are affected, beta will likely be affected too.
For more information, please visit auto_nag documentation.

See Also: → 1783549
See Also: 1783549
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: